New Release - WD TV Live Firmware Version 1.06.34_V (9/24/12)

WD is happy to announce our latest firmware update for the WD TV Live Media Player.

Please post your experiences to this thread.



This firmware update has been removed.


Please Reference :…





Bill, why do the release notes say …resolved daily motion issues when that app was not there on previous firmwares.

Does that mean it was added on 1.06.34?

before 1.06.34_V network movies had no delay, after 1.06.34_V it takes its sweet time before playback starts, buffering? way too long… any way to fix it?

Facebook is still not working, it’s not showing the photos and videos, the icons appear black and the user profile picture appears like when the profile has no photo, also when I try to look at any photo or video it show this error message: “Unable to play the selected file, please see the user manual for a list of supported formats”… I already did a factory reset and it didn’t work.

From all the bugs in the previous firmware my hope was focused in the facebook app, because I liked to browse and watch my videos and my friend’s videos and photo albums in my big hdtv screen. I’m sad about this.

The other bug I still see is when you change the subtitile size, the example is on top of the numbers, this is anoying for my opinion.

Well what a dissapointment…

After waiting this long, none of the previous main problems have been fixed.

Network shares will not connect most of the times, the ring just circles forever, not connecting. A seldom time it works, but its completely random.

Framerate sync doesn’t work, which means jerky playback of 1080p/24 on pal televisions…

Added to this is the fact that playback now takes _very_ long time to start, Sometimes they don’t even start and there is just a black screen with nothing happening.

To think I upgraded from WDLXTV for this…

I’m extremely dissappointed and annoyed.

I believed the long wait was due to proper QC this time…

Time to move on, there are other more apealing products out there with proper support.

Yeah, I can’t get into my Network Shares either. Not at all, not even to the spinning “loading wheel”-thingy.

This need to fixed right away, I can’t watch any of my movies!

If I hadn’t updated I could’ve enjoyed Downton Abbey ages ago.

Can I go back a version only using the system, or do I have to download something through my computer?

I’m using a Mac.

After clearing my password, and turning of auotlogon to network shares, I have been able to connect a few times. Time will tell if its stable.

But startup of playback takes _forever_, something like 30 seconds or more. Feels like forever :frowning:

If you want to downgrade you will have to get an older version on a USB device, change its version number and reboot the WDTV. Not easy.

Updated and can no longer watch my movies. What’s happened? This is terrible. How do I revert back?very sad.

The update says that the WD Remote App (Android) is working now. Installed latest App on Android, but it does not find my WDTV Live, only my WD TV Live Streaming.

The WD TV is in Network via WLAN and works fine. Why the app can not find it?

The android remote doesn’t work here either…

Oh well, it requires v1.1 of the remote program, and the latest version on android market is 1.02…

Not impressed.

I’m extremely dissappointed and annoyed.

 Locks in movies which means jerky playback of 1080p and 720p

This is terrible.

Also I noticed that after turning the device off the connection the the router (the led) still keeps on, consuming energy, I remember a firmware where this didn’t happened and I liked that because that tells me the device was in stand-by mode completetly and not in half.

Also WD TV Live still is not downmixing Dolby Digital Plus to stereo using an HDMI connection since my tv don’t have this decoder inside, only PCM, I tried using autodetect where show in the screen PCM detected but I only hear a noise when I play back any of those files with DD+ only in the stream.

Just came from this topic:

New Firmware Killed My Box? Help?

Just keeps looping at the loading menu, if I hit back on the remote I can get the options screen to show momentarily but not long enough to do anything.   The hard reset buton is not even working.  WD TV Live.

I have the same problem, and im not happy.

So now it’s our duty to downgrade just to make it 50% useful again.

Just installed this and it does not work.  Runs continuous with out showing files except as a flash 

HORRIBLE UPGRADE!!!  should have read this board before I upgraded.

External drive is recognized as well as all iles, but nothing PLAYS!!!

just get the animated wheel and nothing. There had better be a fix

soon or Roku here I come…

Installed all fine for me.

was looking forward to Auto Framerate working, but it has not been fixed.

Boxee box for me…

This has trashed my WD LIVE, just hourglasses, and momentarily flashes video caption, as another user. Withdraw and fix and advise how to get us back up and running please.

Installation wasn’t the problem. It’s what the upgrade broke rather then enhanced.

Do you have an external drive, and does it function as it did before the upgrade?