WDTV LIVE cannot see windows computers in networkshares. but can see in mediaservers

i have a problem with my wdtvlive since 24 december.

my computers dont show up in the video > networkshares. but do show up in medialiberaries

i can see and connect to my NAS (synology ds207+)

i did not update the firmware at that point. (v 1.03.49)

so i disabled the firewall on my windows 7 computer and enabled netbios. removed the computer from the homegroup. and some different stuff but non of the settings does make a change.

the pc has not installed any new updates. and i have removed windows live essential becouse it was cousing trouble before.

my complete setup is WDTVLive > Netgear wndr3700 > 3x windows7 computers/laptops > syno ds207+

the problem started around 24 decembre 2010. i am getting realy despret about this so i hope somebodey can help met figure this out.

PS: i have the wdtv live about a year and it has never let me down :frowning:

This appears to be a common problem with no known solution.  It happened to me a few months ago and I haven’t gotten my network shares back.  Based on what I’ve read here, everyone who has had this problem has had to start using a media server.  I use a combination of Windows Media Player and TVersity.  When WMP is working properly, I prefer it to TVersity.  However, WMP seems to go to sleep on my pretty often and I can’t drill down into the folders that actually contain content.  When that happens, I use TVersity.

For me, using a media server hasn’t been nearly as good as network shares.  If WD doesn’t do anything to fix this common problem, I will likely be moving to anohter product instead of the WDTV Live Plus.

How should WD fix problems with your computers?   I can with 99.9% certainty tell you that the issue is your own network, not a fault with the WD.

ok maybe your right but that does not solve my problem.

the strainge thing is everything was working for a year without problems. now suddenly NON of my computers are visible toe the wdlive i have updated the wdtv till the latest version no changes i downgraded the wdtv to 1.21 still no computers.

i updated the router firmware (WNDR3700) to the latest version still no changes. i have fresly installed a windows xp box still not visible for the wdtv.

i have checked the workgroup. checked if netbios was enabled. checked if dns and dhcp setting were correct

i have searched google for a few hours nobody that could help me.

and its not that i am a newb with computers / networks / linux and **bleep**. i am working as a system/network administrator for 6years.

maybe it is something stupid. i dont mind but now i cannot use the wdtv to its full potential

See if this tutorial for troubleshooting helps:


thank you for the reply. im prety sure that i have done this as i found something like this on a other site.

but to be shure i will follow this tutorial step by step en keep you posted when im ready

regard Marco

Did you try resetting your Router to factory?

The reason I ask is that I have a Linksys.  After doing a firmware upgrade, I couldnt find my computer name(Windows 7 Ultimate) with the shares on the network (Interestingly enough, I could see the Linksys usb share).

I tried everything.  My clue was that I have an XP machine here and shared a folder.  I couldn’t get my WD Live to see that Computer name, or share either.

I  then did a soft factory reset on the router.  Quick setup on the router (basics only) and all shares were now available on the WD Live.

Lesson I learned:  After doing a router firmware upgrade, do a factory reset on the router.  I wouldn’t have guessed that routers play such a role on seeing shares.  I thought on the lan side, the router just acted like a switch.

Yeah I did factory reset the router. As I was testing my wdtv on every step I made. Update the routers firmware coldboot the wdtv and see if it worked! Factory reset and coldboot and check again. But I have found a little hint of the problem. On all pc’s the “net view” command gives an error. So I gues that’s the problem

i have solved my problem.

TonyPh12345 pointed me in the wright direction. with the link he posted earlyer.

the ‘net view’ command gave me an error (system error 6118) so i found the problem, then i was trying to fix the system error but nothing worked. until i decided to shutdown my synology ds207+ NAS. as that was the only device i did see on the wdtvlive player. rebooted the windows 7 computer with the system error 6118. and excuted the command “net view” again! this time it worked

then i booted the wdtvlive and checked if everything was working. and indeed i can connect to my pc agian :smiley: :smiley:

finaly i booted the synology again an everything is still working!

so im not quit sure why the synology screwed up the “Master Browser” at the win7 pc suddenly. but its fixed and i can fully enjoy the wdtvlive again :smiley:


quick fix solution.

if you cannot find a computer in the networkshares on the wdtv. and having trouble with the net view command

(1) shutdown every networkdevice in the network. (exept for the router/modem)

(2) reboot the Windows system.

(optional) run CMD > net view (to se if there is any error)

(3) boot the wdtv to see if you pc is showing up again.

TonyPh12345 wrote:

How should WD fix problems with your computers?   I can with 99.9% certainty tell you that the issue is your own network, not a fault with the WD.


I stand corrected.  I don’t know what caused it, but the Master Browser wasn’t running.  I tried a whole bunch of things and I’m not sure which one took care of the problem.  But the Master Browser is running again and I once again have Network Shares available on my WDTV Live +.

Thanks Tony.

BezImen wrote:

TonyPh12345 wrote:

How should WD fix problems with your computers?   I can with 99.9% certainty tell you that the issue is your own network, not a fault with the WD.




Ordinarily, I let uninformed diatribes like these go by me as so much nonsense.  But, now that you’ve thrown out lots of tasty insults, I’ll school you just a bit.

A technician of WHAT?   As far as anyone here knows, you’re a bicycle tire replacement technician.   Dishing out yummy generic Titles gives no weight to your “Expertise-Factor,” nor does your spelling or grammar.

If you have NO IDEA what the Microsoft Live Essentials had to do with anything, then you have no business being a technician at least in the context of anything having to do with SMB/CIFS.   That issue and the exact cause of it was SO WELL KNOWN, and SO WELL DOCUMENTED (and now SO OLD NEWS) that it’s not even up for discussion.   And it’s also been corrected; at least with WD Products.    It still affects quite a few other products that aren’t WD…

Saying that you’ve done EVERYTHING and still can’t see a single share on your network implies more about your lack of ability as a “technician” than it does for WD’s ability to work on a proper network.

I’ll restate the fact.  Of the dozens if not close to 100 users on this community, 99% of EVERY ISSUE that I’ve corrected has been with something OTHER than the WD.   I can bear that out with fact.

Until you, Sir Technician Expert can provide REAL EVIDENCE to the contrary, please, do us all a favor, and smash your equipment with a hammer and move on to somewhere else.

Ok.  Great.   Now if you’d like some help with the issue, please start another thread (since this one is already marked as solved.   Twice.)

TonyPh12345. indeed this one is market as solved. a i explaned. the link you gave me. showed me where the problem was. and i finaly found the nature of the problem. i solved it and marked the topic as solved. (i gues thats why the solved button was there)

and this topic was already dead becouse of the useless flame posts that will not help anybody.

i thank you tony for pointing me in the wright direction :slight_smile: