WDTV is freezing up!

I have a WDTV WDBYMN0000NBK and I am running what I think is the latest firmware version 1.02.17. I am having nothing but problems as in every few days I have a freeze up where by when attempting to play any video it simply displays the circling arrow on the screen and never starts. The only thing that works to fix the issue is a reset to factory settings. Anyone have any solutions??

1 Like

Sorry, I can’t help! But I had this too, and BINNED the unit, it had never worked right from day one! I know that is no solution, but I haven’t had it with a new unit (£70-odd later). Wouldn’t switch off with remote either. IT’S A DISGRACE. Good luck. (I don’t mean to say there are no solutions, but I honestly think the unit I threw away was an expensive piece of junk).

Thx for the response! I have to admit I am seriously thinking these are not good media boxes! I have had 4 of them and had to return two so far. The reality is there has not been a firmware update from what I can tell since 2014 and there are obviously many issues. I just purchased a android media box from China for a big $35.00 and it appears to be working much better then the WDTV which certainly says a lot. I have not tossed in the towel yet but I have to say I have never had any electronic device that has caused me as much grief as these WD TV boxes

1 Like

Agree. But (now I’m going to sound as tho’ I’m arguing from a contrary position from what I wrote) you know what, I haven’t had ANY grief from WDTV, unit No.2! Ditching the first one left me not only financially disadvantaged, but traumatised, you might say. So I spent time looking to see what other options are on the market and discovered to my amazement that for all its faults, WDTV Media Player is decidedly considered the best choice on the market. So committed to another, even before I took it out of the box, I scanned many of the posts on here before I made any move to set it up. As a result of that, I placed it on a ‘skeleton stand’ I made from rigid plastic food containers cut down, so that I was certain air could circulate round it from every direction. And took note of another post which said select ‘list view’ for media library as it won’t tax the thing’s memory so much! But only those two things. The next thing, if the Community is anything to go by, seems to be the hurdle of whether to update or not update the darned thing. Again, I’m not going to make any move. Oh, and the only other thing that might be of use is - register it on WD’s site. You’ve probably done that. So that you can create a Support Ticket. With this second unit I did create a Ticket once (an apparent password problem that turned out to be not a password problem but a Windows ‘sharing’ option, one of several required) that I hadn’t set up, so the Ticket, and the help, turned out to be a success.

I have the same unit (WDBYMN000NBK) and 1.02.17 firmware with a similar problem, when I pause a video file more than once and try to watch that video I get the circling arrow, like it’s trying to reload the file. The only fix I have found is to restart the unit and then I can watch a video file. So in the end, once I start a video I have to watch it completely with no pauses. Sure would like a fix to this because I really enjoy the unit otherwise.

Y’know what Tony, if your question doesn’t get an answer within a couple of weeks, whilst leaving the question here, open, it’s probably best to adopt the assumption that the darned question isn’t going to get answered. My posted question got a couple of replies and was never concluded, that’s why I say that. I noticed that on Amazon, people writing scathing reviews about WD TV got replies from a WD Support rep readily appearing and saying to them, you should have come and asked us for help! Here though, on WD Community, I’ve hardly seen Support rear their heads at all. Once or twice maybe. But if you do take out a Support Ticket it should solicit some help, even if not within their 48hr (I think it is) response target.
Weirdly, I did have the ‘circling arrow and the video never starts’ that you describe today. It happened after I was fiddling with the settings trying to wipe out its Library so I could rebuild it. As I have said, on this, my second WD TV unit, I have had no problems with it. But without being able to be specific enough, I can give you a rough idea of what I was doing and where I was when I fixed it, just in the hope it has some relevance. You know the main ‘tiles’, the large ones you see on WD TV’s ‘home’ screen? If you press ‘okay’ to enter ‘videos’, well, without going anywhere, when you are there, you get some more options (icons) that you don’t see elsewhere. Once I went through those options, the problem went. I just wish I could say specifically what I did, but those options might be where you can resolve this. (It’s okay to mess around there, I did. Some of them toggle ‘on’ and ‘off’ and you can try both positions without ill effect). Whatever I did, my unit is exactly how it was before I got ‘the circling arrow and the video never starts!’ (It’s only a guess, but it may have been playing with the ‘content’ icon where I fixed it!) I wish I could be more help.

I own a WD TV WDBPUF0000NBK since March 2014 and every time I want to watch a video need to reboot it as well.
Pausing video can’t be done either
I logged a support case in 2014, but they closed it after minimal troubleshooting.
It’s been through firmware updates & downgrades but still persists.
Easiest way to get it working, is doing a device reset from the menu.
I’ve just logged another support request today, as I found out a friend has the same type of unit, but does not have this issue!
A suggestion from this community was to switch off all devices on your network, then switch them on 1 by 1 until the problem occurs.

I had five at one point and now have none. Sent three back and got replacements but soon after same issue with lockups and factory resets only fix. I finally purchased 4 android media boxes for 35 dollars each and have not since had an issue. They work perfectly. I loved the wd boxes but western digital is simply not providing firmware updates to fix the issues so they are now junk

1 Like

I have this exact same problem. Unit worked fine for a couple of years but now I have to reboot the unit at the end of watching a video. Have also tried rolling back the firmware and disconnecting it from the network.

This post was flagged by the community and is temporarily hidden.

Well I have had 5 of these boxes and had similar issues with all but one I believe. WD will replace and trouble shoot but in my humble opinion the issue is no firmware updates. Without the firmware updates the boxes will cause you issues and as I said I have had 4 out of five do the same thing over and over. It locks up and then requires a factory reset to fix it. I do not have these WD boxes anymore I took all of out in my driveway and smashed them with a hammer in hopes of not letting these things drive me completely insane. I then went and purchased a few andoid media boxes and they work very nicely.

I logged a call with WD support, they contacted me and got me to send them a diagnostic log.
The level 2 tech support said level 3 support would contact me within 48 hours, they haven’t and now my call is closed! Pathetic. I remember seeing custom firmware on the WD TV devices that allowed you to install Linux. I think that might be the only way to fix issues from now on - do it yourself!

Swines. Log another Support Ticket. Don’t let them get away with it, the lazy s…s. I got a reply from a Ticket of mine after 72 hours with an apology for the delay. The more useless they are the less you should let them get away with it.

I actually posted my painful experience last week and received a call from support. Sadly they ignore my call preferences EVERY single time (only being able to take calls after week).

I had major issues with the replacement box they sent me, and had the ‘continually loading’ issue. I haven’t seen it since the update, though some files have taken a long time to load. BUT…I don’t connect the box to the network, and have all my files on a portable hard drive. My only confusion is why some people/boxes have zero issues, while others simply wont work. Perhaps there are manufacturing differences, or it’s down to the network/files used.

They never should have released these boxes on old hardware, while upgrading the capabilities. Media files have only increased in size and complexity, and these boxes just can’t handle it. Add in the lack of proper software support.

Yes, from the two WDTV boxes I’ve had, it does seem to me that there are ‘good’ and ‘bad’ units, because zero problems on this second one (apart from fixable ones; down to me needing to do the pc/WDTV settings correctly), yet nothing but problems from the first one that I threw away. I don’t like what this is pointing at, shell out for another to see if you can get a problem-free one! Although that would be a risk-free thing to do as long as you test it thoroughly within the two weeks/30 days (whatever it is, required period) expires during which you can return it and claim a refund as it wasn’t fit for purpose.
Interesting, about the Android one, but from what I’ve seen posted (on other posts) on here, the WDTV box is supposed to be the only one that in some ways, does more. (What those things are I can’t recall). But with regard to you thinking the Android’s better, well, if it does what you need it to, then that’s all that matters.
I admit that for me, if this second WDTV does start to play up (someone above said theirs was alright for the first two years), I don’t much like the idea of spending another £70 on a further one (unless a new release model), but will buy something else. Although having said that, I would be kinda happy to get two years trouble free, for £70! What I mean by that is if two years usage, then might consider that okay and so might consider another, as long as test it really thoroughly, put it through all its’ paces with the idea that it can be sent back, as long as quick, within the permitted (2-3 weeks?) window during which a full refund can be claimed. You could do that.