WDTV Media Player hangs and locks up - Solution?


i have bought my WDTV Media Player Box a few month ago and it will absolutely always lock up and show the spinning arrow.

I always have to power-unplug the box and re-power it.

Also, it will stop playing movies in the middle of the movie and again we have to power-cycle this thing.

I searched this forum and found many many same posts about this, but couldnt find any single solution to it.

I have the “newest” firmware from December 2014…

Now, is there any help here, any solution or does WD just want to sell non-working boxes, collect our money and just forget about any end-user-support?

I am very frustrated with this “product” and if there is no help in sight this will be my last product of WD!

Help please, fix the bugs, release a new firmware! :slight_smile:

(Sorry for my english, as this is not my mothers tongue :slight_smile: )


I recommend you try a factory restore.

You can either try it from the settings or by clicking the reset button on the bottom of the WD TV for 1 second.

Hello, I had the same problem with all 5 of my players running firmware 2.02.32. So I rolled all boxes back to Firmware 2.01.86 and that solved my problem. So if your box has firmware 2.02.32 then that might be the problem.

To roll back got to  http://community.wd.com/t5/WD-TV-Live-Streaming/2-02-32-Firmware-no-longer-allows-content/m-p/781937#M32423

Hope it helps

I have had the same issues on my WD. Videos are freezing, the unit stops responding and I have to pull the plug to reboot. They have happened just recently though, within the last couple weeks, and I don’t remember updating my FW. I will check to see if I have the latest FW and if I do I will rollback tonight. 

The rollback fixed it for me. I didn’t even have to do a factory reset. Now it loads quicker, and plays without freezing. Before the rollback it was freezing after playing 20 minutes of video, it would do multiple boots and I had a heck of a time watching youtube. It would take several tries to log into youtube and reboot several times in the process. I also had no sound on youtube unless I played a video off of a hard drive first. All that is now fixed.

It makes you wonder why the idiots they had doing the programming didn’t realize that these things happened after the update and why they didn’t do an automatic rollback for all of us.  I guess they just had morons working for them. Still after all this time they should have taken it upon themselves to trash the new FW update and give us back a device that actually worked.

Before coming to the forum, I was ready to trash the device and go get something else. I mean, you have to have a lot of patience to wait through multiple reboots and the device telling you it is compiling media over and over again before you get to watch anything, and then freeze after 20 minutes playtime. Thank God for the intelligent people on the forum for the help.

1 Like

that didn’t work for me!!

for me disabling wifi-direct in the network settings worked. have a try.

Thanks Robert. The rollback seems to have fixed my freezing issue too.

Hi all, it has driven me crazy and to the point where I have now signed up to find help. The fact that there are no new updates( and now can’t connect anyway) , the device keeps freezing after 15 - 30 minutes and no matter how many times I have tried to contact WD for help or a solution I don’t hear back. I am hoping someone can help with the continual low storage memory message I keep getting as well.

Anyway that is my vent, so hoping someone can advice as I have also tried all the ideas in this thread as well.


If you rollback to version 1.13 you will find most of your problems will disappear.