WDTV HD Live No Longer Connecting To My Network

Hi guys,

I’ve had my WDTV Live media player for quite a while now and it’s been flawless at HD playback using an external HDD connected to the WDTV via the USB port. However, I bought an Asus USB-N13 wireless adapter a few months ago so I could stream my SD content from my home computer.

Everything worked like a dream right from the start but now all of a sudden, my WDTV just won’t connect to my network at all. I’ve not changed a single setting in the router or anything. It keeps telling me that I have limited or no connectivity to the network each time and when I go to the Check Connection setting, it fails at the DNS server stage.

I’m running the latest firmware on both the WDTV (1.06.15) and my router (Edimax BR-6574N).

I can access my wireless network through my iPhone and iPad perfectly as well as my laptop. Everything works perfectly just the WDTV not connecting.

Can anyone please help?

Thing I’ve tried so far:

Rebooted router and WDTV several times

Unplugged WDTV unit from mains by removing power cord from the back and re-connected after a minute

Removed wireless security completely and tried connecting to my network

Set WDTV to default settings

Checked WDTV to make sure workgroup is same as my PC



It is a quite recent problem.

I also have it.

My computers:

xp sp3

seven sp1

When I click on network on wd nothing happen

All PCs and wd are in the same workgroup

Glad to hear I’m not the only one suffering from this issue. I don’t think it’s to do with the computers on the network but the WDTV’s inability to connect to the wireless network through the Asus N13 dongle.

Can anybody help then?

I tried re-installing the 1.06 firmware but this is not possible probably because it’s already running the latest version.

Your comment in the first post gives me a clue. . . .

   "limited or no connectivity to the network "

…because something like this happend to me recently, and I managed to see what caused it and fix it.

Something in your network likely got its “brains” scrambled, and powering it all off, top to bottom, even the most insignificant component, needs to be powered off for a few moments, and each item should be brought back in a logical sequence.

Here’s why I say this: 

When I got the same message, I had my main Win7 PC on and using it (and thinking it was sluggish), so I booted up the WinXP machine.  I happened to be sitting in front of it when I got the message that I had limited connectivity.  I then did a bandwidth test from the Comcast test site:  my usual 30mbps speed was around 6mbps.  I checked the Win7 and it had the same low speed.  Ah, it’s Comcast, ah, it’s the router.  I checked the WDTV, hmmm, it could stream Netflix, etc,  Weird. I gave up and went to bed.

The next morning I told my wife we had lousy bandwidth, and she said it seemed to be working for her PC.  She did a speed test and got 30mbps.  Hmmm, what’s different about her setup and the WDTV versus my PCs?  Well, I have a Lynksys 4-port switch at both my PCs, she has none, and a different brand (D-link) was connected to the WDTV,

What to do?  I pulled the power cord off the first Linksys switch, waited 10 or more seconds and plugged it in and I had 30mbps speed again!  Did the same thing to the other switch, and got back the 30mbps speed.  These switches have been connected for around 10 years, are always on and never caused a problem.  Weird, again. 

A couple of weeks later I had the same problem with the same switches.  It was storm season, and one day the house power blinked for less than a second; the lights really never went out; neither did the network (so I thought).  But a half hour later I  tried to send a file from the PC to the WDTV hard drive and it said it would take a couple of hours and the transfer speed was in MB, not GB.  That’s when I remembered the power blip.  I removed (and renewed) power to the two 4-port switches and was up and running again. So, I suspect the switches never fully went off during the blip, as they would do in a full bore “power’s out for a while” condition.  This situation scrambled their brains; and only the brains of the Linksys switches, not the D-Link.

Now,  we have a fully wired cat5 house, and all network items connected are wired.  (BTW, when I tested the PC’s wireless connectivity, that worked fine; another indication of a problem in the “wired” components) This situation has likely happened before, but usually power is off for as least longer that a split second.  Besides, whenever I know power has gone off, I always reboot the system from modem to PCs, and all the gizmos connected to TV; incl. the TV.  I remove all power from the entertainment system, too.  When I do all this, I very likely often fixed some connectivity problems I didn’t know were there.

So, when I say to shut down all power for a few moments so things “really” turn off before power is restored, and do this for all units that are even remotely involved with one another (meaning, you can leave out the toaster) I am not kidding.

OK, so you do all this and things don’t improve?  I would say then that a component that builds your network is bad; likely the router, switches, wires etc.

So, just 'cause the WDTV acts weird, don’t blame it right off; it could be being victimized by the “real” problem.

Good luck with the fix.

I’ve already tried powering down my modem, router & PC and WDTV but no luck. I’ll power them all down today for 10 mins and see what happens after I power them back up.

"OK, so you do all this and things don’t improve?  I would say then that a component that builds your network is bad; likely the router, switches, wires etc.

So, just 'cause the WDTV acts weird, don’t blame it right off; it could be being victimized by the “real” problem."

I completely disagree with this sorry. I don’t believe my router is at fault as ALL other wireless devices connect fine. These are: 1 laptop, 1 iPhone 4, iPad 2, 3 Android phones & a recently purchased WP7 phone. They all work flawlessly when accesing the internet or performing other tasks such as streaming videos to the iPad from the PC wirelessly.

I have 2 WDTV’s in my house which both use the same Asus N13 wifi dongle and both have exactly the same symptoms. It seems to be an issue with the driver for the Asus dongle being used by the WDTV in my eyes.

Everything has been working perfectly until Sunday last week. I’ll still try powering everything down again and see what happens. If this fails and there’s no other solution, I’ll need to take it further with WD as I’ve invested quite a lot of cash in the whole setup for it to let me down now.

My wireless configuration is very simple, I have a Windows 7 PC with shared folders from one of the internal drives on a wireless N router which is getting the internet from a little modem. It’s quite a stable fibre optic connection.

The problem IS wd for me too.

I have a wd and a popcorn hour and I’m able to see the network shares using popcorn.

I’m able to see the share from one pc to the other too.

I have a wired network and not wireless.

Addendum: some months ago I was able to see network shares from wd

Same thing here too. Just all of a sudden WDliveplus “problem connecting to network”. I can acess shares through settings>filemanager but through media servers, streaming ANY media, vid, pics, music…cant connect. I have reset, reconfigured etc and same thing.

I have 2 of these boxes and 1 works where ever I put it and 1 doesn’t which points 100% to the unit. It has the newest FW so i cant do an update…anyway to force new firmware on it?



As mentioned by someone earlier in the thread, I completely powered down my router, modem, both WDTV units, and flicked the switch on the wall socket to off for 10 mins. Turned router and modem on first, then my PC then the WDTV units and now it’s working like the day I got it.

I wouldn’t really call it a fix but more of a workaround or bug in the firmware. Hopefully it’ll be fixed in a future firmware.

If this hadn’t have worked, I would have gone down the unofficial firmware route to fix my issue.

Hopefully this might help a few of you out there.

Glad to know you got it fixed.  I hope you had a beer or two while you waited those 10 long minutes!  (Kind of like watching paint dry.)

It doesn’t hurt, and just might help, to do this monthly.  There are all sorts of things that can bung up an electronic gizmo.  Think of it as a “reboot” of the entire system once in a while.

Your mention of the wall switch made me wonder:  Could it be possible that someone started to turn of the wall switch, realized their mistake, and fliped it back on immediately:  kind of like a blip from the power company?  If possible, don’t hook this stuff to a wall-switched outlet.  The only switch should be on the surge surpressor – and one that can’t get bumped off accidentally.

The wall switch is never tampered with by anyone else I can assure you. As for power issues, everything runs through a surge protector.

I’m getting new issues now where the video playback is jumpy or very slow. It’s almost as if I was fast forwarding it or something. Each time I sit down to watch something, I keep getting this annoying problem. I get this issue even after powering everything down like I did before. Today I tried again on one WDTV which has been causing me issues worked fine an hour ago when I tested it with multiple files. I then tried the same thing on the second WDTV & kept getting the playback issue.

I’m now thinking of ditching the Asus adaptors for homeplugs as I’ve no idea if/when WD will release an update.

I’ve been having the exact same problem.  Everything worked fine for months and then one day my WDTV has no connection and can’t find my ISP.  I tried all the same things you did with no fix.  All of my other devices worked on my wifi as well.  

I’m about to try the 10 minute power down and see what happens.

By the way I use a AirLink101.

10 minute power down did not work for me.  Not sure what to do next.  Any advice out there?

When will this issue be fixed??

Are there any WD reps on here that can help?

Tried something different today. I moved my TV & WDTV very close to each other and there was a slight improvement but not fully fixed. Playing ISO DVD images caused the WDTV to reboot which is annoying. The random rebooting happens with both units. I then tried unplugging the wireless adaptor & connecting the WDTV directly to my router using a network cable to check out the performance. It worked flawlessly even the ISO files. This leaves me to believe that the wireless adaptor is at fault or the WDTV cannot control it properly. My iPad always works perfectly with all files (except ISO’s as these aren’t supported yet) no matter where I am in the house. Since WD won’t fix this long standing issue & nobody else has a fix for it, I have the below choices: 1. Sell both WDTV’s & both wireless adaptors & buy a couple of Apple TV’s with the money & spend some time converting all my ISO’s to avi; 2. Keep the WDTV’s & take a risk by spending lots more money to try out home plugs ( then sell the wireless adaptors); 3. Find an unofficial firmware which works better than the current firmware to see if my issues are fixed.

Just to update this, I went for option 2 in the end which is the homeplugs. They’re 200mbps Newlink ones and everything works flawlessly with the odd reboot here and there which I can live with. So for all you guys out there experiencing issues with using wifi adaptors, save yourselves a lot of time & hassle and just buy homeplugs. It provides a much much better 98% trouble free experience.

Recently though, I’ve noticed that the WDTV’s have stopped detecting my computer altogether. When I try clicking on Network Share option, nothing happens at all. It just doesn’t respond with an error or anything. It still allows me to access Youtube etc. The only way to fix this is if I restart a Windows service called ‘Server’ on my computer. After a minute or two, everythings back to normal. Unfortunately, I’m having to do this each day. iPad works fine without restarting any services. It seems like WD have stopped supporting this device completely so it’s really up to us to fix any issues that crop up. If I find any more fixes, I’ll post them for others to try out. Wish I’d bought an Apple TV now as there’s nothing worse than buying a product only to realise later that there’s no decent manufacturer support for it!

@wutang200 I have exactly the same issue.

I have 2 pc (seven and xp).

Click on network share and nothing happens

I tested shares using popcorn hour and xbmc and everithing is ok

I am having the same problem I have tried everything, and still does not work. this have to be a firmware problem. I need a solution bad.