New here

Hey guys,

So I have a first gen wdtv live, upgraded to the new 1.06.15. Wasn’t having any problems, until recently.

Now when I used to go to ‘network shares’, it would detect my laptop, and then from there detect the external hd’s connected to the laptop.

Until recently, all of a sudden it isn’t detecting my laptop anymore. I know once it does that, the drives will be detected. So my question is why isn’t the computer being detected now??

Both the laptop and the ethernet leading to the wdtv hub are both connected through a linksys wrt54G router.

Any thoughts would be much appreciated.

Did you figure this out?


No I didn’t. I honestly have no idea. This WDTV Live is such a sensitive machine. I’m afraid to sneeze around it thinking it’ll stop detecting my network lool. Usually when it doesn’t detect the laptop, I’d just do a restart of the laptop and it would work but now I got nothing. I tried resetting the firmware back, but still got nothing.

The thing is that I can still connect to youtube and other sites through the WDTV, just can’t detect my laptop. So I know it’s a network problem, and seeing as how rolling back the firmware doesn’t help, the problem is def a network one. I just have no idea what to try. I’m running Windows XP. First time I’m having this problem so that’s why I hit the boards to see if anyone else had this problem.

Anyone have any idea? I’m lost for ideas. I mean both are on the same workgroup, it’s just not seeing my laptop in media shares at all. Is this a problem with the router? Very frustrating to say the least.

So I went upstairs to check my sisters computer (she is connected wireless to the network), and she can see my folders that I am sharing, so at least it’s working for her. So obviously the problem is why isn’t the WDTV detecting my laptop device through ‘network shares’. I realized something else:

Before when I used to turn off auto log in and then back on, it would prompt me for my network password. It does not do this anymore. Even though this is connected with an ethernet, it would still ask me before to put in the password, now it doesn’t. What’s going on with this?


I was assuming before you hadn’t changed any config items, but now after that last one, I can see that SOME changed.

It’s no longer asking for your password because you turned “Auto Login to Network Shares” to “ON.”

If you turn that OFF, it will resume asking you.

Also, as to your first problem, make sure that your WORKGROUP name matches all the other computers.

Hi Tony,

Thanks for your reply. Yes all the workgroups are the same, including the wdtv. Actually, now that I turned the auto log in to off, it actually still doesn’t ask me. When I restart the device, it just automatically goes back to ‘on’. It’s very bizarre.

The upstairs computer, which is WiFi, is detecting my shared folders. As as a test, I also shared the upstairs computer files and the wdtv is picking that one up as well.

It will not however pick up my laptop, which is connected by ethernet. It is very bizarre. Is there anything I can check on my computer, or router settings?


Hey Tony,

So I actually connected another one of my desktops to the router (same way as my laptop that I’m trying to have WDTV see in network shares), and the desktop computer is detected by the WDTV. So the problem is now clearly my laptop. Everything is the same in terms of workgroup etc, so what are some possible things I can check out and change on my laptop (in terms of networking etc) that might allow it to be seen. I thought the WDTV was a problem, but after it detects the desktop it has to be my laptop that is the issue.

Any suggestions??


See if this tutorial for troubleshooting helps:


I got it fixed thank you. I went to that link and the first thing I did was go to the command windown and type in ‘net view’. I realized I was getting an error 6118. Wasn’t opening the workstation etc. So clearly there was a problem there. I did some research and one thing that I did change that I completely forgot about was a enabled my firewall, which was off before. Frankly I didn’t think it was be a big issue since in the exemptions section ‘file sharing’ was checked…but I guess it was still causing a problem. Since it’s all connected through a router with it’s own firewall, I don’t need the windows one enabled.

So I disabled the firewall and then restarted the computer (this is key! you have to do this first before powering up the WDTV), and all of a sudden it is detecting the network shares!

Also, when going back into command and typing in ‘net view’, it detects everything.

Huge help Tony, thanks again!

It seems obvious your laptop is not sharing.   So, forget about the WDTV for a moment, and check out the network sharing between computers in the home with  one another and the laptop; i.e. your sister’s PC and your desktop.  Can all the computers see the shares from the others; e.g. between sister.s and desktop. between these two and the laptop?

If you find a sharing problem this way, once you fix it, the WDTV will likely see the laptop again.

If your Live is like my Live Plus, a share needs to be made for all folders (on the laptop) you want to share, e.g. music, videos, photos as there is a menu choice for each of these on the WDTV.  If you can see the laptop shares under any of the WDTV share options  for the above media selections, but not all, then the one you can’t see is not being shared, or shared properly.

Also, what version of Windows is on the laptop?  The desktop? Sister’s PC?

Hey Mike,

Thanks for your reply. I actually just posted the fix before you did. I did indeed check between my sisters and other desktops connected to my router, and all were being shared fine. My sister’s computer is wireless, and she was seeing my shares just fine.

As I posted before, it was the enabling of my windows firewall that prevented the WDTV from seeing it. Which is kind of strange, because it didn’t let the WDTV see the shares, but it did let my sisters computer see them. Kind of bizarre but finally got it to work.

I honestly overlooked the enabling of my firewall. Me and a buddy were trying to solve a gaming VPN issue and for some reason I must have enabled it, but even so…seeing as how in the exceptions section I had ‘file sharing’ checked off, as to allow windows firewall to let it happen, it still didn’t.

This could be a huge issue for others, so I would def check that out first!