WDMYCLOUD 1st Generation now on my Network only

I decided to go ahead and make my My Cloud 1st generation for use on my Network. The first thing I did was in Settings where I changed Network Mode to Static. Images below shows it on my computer now and no Internet Access. Click on, tap, or activate images to enlarge them.

I also pinned it to Quick Access and the Start Menu.

Here is what shows for Cloud Access now on my Dashboard. Click on, tap, or activate image to enlarge it.

Static IP address for a NAS is generally a good thing.

Just to make things cleaner, you might want to assign the IP address From the router and not from the NAS.

This would avoid unintended problems if you get a new router that does IP address assignments in a different subnet than you NAS is requested. This might result in loss of access to the unit.

(and while you are at it. . .you might want to see if your ROUTER can block all internet access to a MyCloud Gen 1 device that is running OS/3 - - - > From a security perspective, this is not the most secure device around)

May I know how did you do it please? Been trying for months to set it up for local access but in vain…

What exactly are you looking for help with? How to configure a My Cloud for a static IP address, or how to reserve an IP address in the local network router? Or how to access a local network My Cloud?

For a static IP see the following WD Knowledge Base Article:

How to Configure a My Cloud Device with a Static IP

For reserving an IP address for a My Cloud within one’s network router or gateway use your favoriet Internet search engine and search for how to reserve an IP address on your router. Each router model is different and has different ways of reserving an IP address for a client network device within the router’s administration setup page(s).

If you are having trouble accessing a local network My Cloud using a Windows OS computer there are a few things to check within Windows. Ensure SMB1.0 is enabled. Ensure that Network Profile is set to Private.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10 and 11

One generally uses Windows File Explorer to access a local network My Cloud on a Windows PC. For Macintosh one would use Mac Finder. To make things easier one can “map” a My Cloud Share.

How to Map a My Cloud or NAS Device on Windows

How To Map a My Cloud or NAS Device on macOS


1 Like

Hi Bennor:

While I’m somewhat familiar with the MyCloud devices, I’m not a networking expert (far from it). But I have a question about SMB settings. I’m familiar with enabling SMB1 to view the MyCloud content over a network but I’m not sure why this is necessary. SMB on the MyCloud can be set to 1, 1 and 2 or 1, 2 and 3. So with the MyCloud set to SMB 1, 2 and 3, why is it necessary to enable SMB1 in windows to see the content (when the computer should be able to connect under SMB2 or SMB3)?

See the WD knowledge base article about enabling SMB1.0 for a possible answer to your question. From that article WD states the following:

The “Network Browse” function has been disabled on Windows 10 v1709 and higher and Windows 11.
SMB 1.0/CIFS File Sharing Support has been disabled on Windows 10 Windows 10 Fall Creators Update version 1709 and higher and Windows 11.

The Computer Browser service relies on the SMB 1.0 protocol to populate the Windows Explorer Network node (also known as “Network Neighborhood”). This legacy protocol is long deprecated, doesn’t route, and has limited security. Because the service cannot function without SMB 1.0, it is removed when SMB 1.0 is disabled.


OK, thanks. I think get that now. But on my other NAS drives (Synology DS118, DS218) I don’t have SMB1 enabled on my computer but can still browse the content over windows 10 file/network explorer(?)

May come down to WD firmware vs Synology firmware. Could be WD is using a older (likely very old) version of SMB in it’s OS3 firmware. Could be simply how each has configured SMB/Samba. On an v4.x single bay My Cloud running the latest firmware (released yesterday), the Samba version (via the ssh linux command: smdb -V) is 4.3.11 (released July 7, 2016). Where as Synology DSM 7.0.1 (via ssh linux command: sudo smbstatus) indicates a Samba version of 4.10.18 (September 18, 2020).


Hmmm… Interesting.

Thank you Bennor. All my problems solved.

I worked on this problem on-and-off for several years.

I am never able to reliably see the OS/3 devices in the “network” section of file explorer. . .but I always have been able to access the drives by addressing directly (either with the ip address or the device name).

Whatever the issue was; I know that it was resolved with OS/5. (one of the few things I liked about OS/5). I suspect that at the core; it’s a Windows Master Browser issue of some sort. Whatever. . .I learned to live with this bug.

I, too, have found OS5 more reliable for local, and particularly remote, access (I have two Gen 2 MyClouds).

Oh - - - when I was running OS/5 - - the ability to connect through the app was quite good.

And OS/3 performance (through the app) just seemed to . . .degrade. I was running an EX2 on OS/3; and EX2 on OS5. Plus an old mycloud Gen1 on OS/3.

I had quite an investment in MyCloud devices: 2x Gen2 MyClouds, 1x Gen 1 MyCloud, 1x Gen1 MyCloud Mirror and 2x Gen 1 MyCloudEX2. I got rid of the Gen1 MyCloud and MyCloud Mirror and re-purposed the Gen 1 EX2s as a local media server for a friend and a local security camera storage at my vacation home. The two 2nd Gen MyClouds are media servers for my kids (dad can still access them remotely when necessary)

Having said that, I now have 2 Synology DS118 single bay NAS and 2 Synology DS218 dual bay NAS devices for all other needs!