WD30EZRX recognized 2TB only

Hi,

I’ve just bought a WD30EZRX-00MMMB0 from a retail shop in Hong Kong, however after I connected the disk to my little NAS (Board: Zotac H67ITX-C-E) running on Windows 7 Pro 64bit, it recognized approximately 1.81TB only.

I thought this could be a problem of BIOS vs EFI, so I’ve tried to re-install my Windows 7 with EFI, convert it to GPT, yet the installer recognize only 1.81TB as well

I’ve then tried to boot into a Linux, and even connect the disk with another PC, all return the same result - 1.81TB only

I wonder could this be a problem of the disk itself as the disk size (Not partition size) shown 1.81TB everywhere.

Any suggestion?

Below is a screenshot I’ve captured, sorry that it’s in Chinese. Thanks

disksize.jpg

Regards

Ho

it’s your nas board that’s limited.  it’s probably using a linux kernel that is older.  see if you can update it with a more recent firmware that recognizes drives greater than 2 tb.

It would help if you switched your language back to English when capturing the screen shot.