Problem with 3TB drive

Dear readers,

as a not so proud owner of 8pieces of 3.0TB WD30EZRX drives - green variety. I have a problem. When connected to the machine via USB external closure Linux only sees about 800GB of storage. I have not yet connected directly to mobo because I don’t have any ports free. I have used 2TB and 3TB drives before and have had no problems. Actually I tried the USB enclosure with an old 2TB seagate and it worked. So there is now something I am doing wrong. I am suspecting I have to set some jumper. Any help would be highly appreciated. The seller just wished good luck and told that I can always return them but I would rather not because I need storage - now.

Best Regards


i think its the usb case that is the cullprit

it can only adress maximum 2tb drives

free 1 port of your motherboard and confirm that your motherboard accepts the new drive

If it isn’t the case make sure that Linux can recognize  more than 2T. In Windows drives larger than 2T need to be formatted GPT instead of MRB.


Please check this thread for an enclsure that works!

Don’t forget to give  Alucardx23 kudos!