WD1200 Problem, drives not powering up

I have 10x WD1200 drives that I use to use a while back for video editing

All these drives were fitted in removable caddies, so that I could swap them around as needed, depending on free space.


The other reason I had these setup in such a way, was that I would sometimes paired drives so that I could set them up as a striped volume, in order to get faster read/write speeds for video editing.

It’s been some time since I’ve used these drives, and not thinking anything of it, I decided to throw out my old dinosaur Windows XP computer which was used with these hard drives.

Just recently I instead purchased a Dual SATA HDD Enclosure Caddy Case Docking Station


thinking I would simply plug each drive into the docking station (using a IDE to eSATA converter) and then just transfer whatever information I needed to a newer 4TB WD drive.

Well… It seems my workaround has been much more challenging, ONLY WITH MY WD hard drives!

I also have over a dozen Seagate Barracuda 200 Gbyte drives, and as mentioned above, this has worked ABSOLUTELY flawless. I plugged each (individually) using the IDE to eSATA converter, then plugged them into the Docking Station, and without a hitch, each drive mounted.

It’s been quite the opposite with the WD1200 drives. I’m not sure if this sounds right, but It seems the drive isn’t receiving enough power through the dock, as I can’t hear the head move after turning on the power to the docking station. Is this a possibility?

what other solution may one suggest, because the thought of not seeing what’s on these drives is starting to really worry me.

At first I thought maybe the drives are shot (because they haven’t been used for such a long time), but then I questioned the thought, especially knowing the Seagate drives mounted and worked just fine.

Any suggestions?

I’m guessing there is no one willing to help here?

Nearly 6 years later, I am having a similar problem. Did you ever figure it out? Mine was working fine when I connected to it yesterday. I then hit Eject on the mac it was connected to, which somehow caused it to power off, and I have not managed to spin it up since then.

I do welcome all victims of China mainland, whom paid a significant amount of money = they were scammed, so to buy a 7$ USD worth of HDD dock, at the price of 40 $ USD or higher.

Gentlemen, WD has nothing to do regarding responsibility about external HDD docking stations.
You better ask refund from the Chinese whom got your money, and sold to you unreliable technology.