WD UTILITY SOFTWARE & WIN 10 - Brand New My Passport Ultra 3TB Fails WD's Complete Drive Test

12/13/15 UPDATE:
As suggested in another post in this forum, I tried running the Extended drive test using the Data Lifeguard Diagnostics (DLG) software (downloadable on the WD site). It took 13 hours to run on the 3TB drive, but it PASSED! This leads me to believe that the WD Utilities software (and YES, I am using the latest version) has problems - probably due to Windows 10. I suspect the problems are inconsistent, since my first drive failed BOTH the quick and full tests and this drive passed the quick test but failed the full test, and then PASSED the DLG test.

Anyone else having problems like this?

I’m on Windows 10. Just got my second 3TB My Passport Ultra. Had to return the first one because it failed BOTH the quick test and the full test. This new one just arrived yesterday and passed the quick test but failed the full test.

I called support. They say they have no record of problems with their utility on Windows 10, but they also say the chances of my getting two failed drives is really rare. They suggested trying it on a different OS (my husband’s computer is on Win7, so I’ll try that next).

I saw a post here about a problem with USB 3.0 vs USB 2.0. I’m hooking my drive up to my laptop using the 3.0 port. I’ll try the 2.0 port, but doubt that’s it, since it is recognizing the drive just fine.

I also uninstalled and then installed the latest WD Utility software and tried again. Same result.

Anybody else have this issue or any solutions?


I see you were going to test the unit on a different OS as suggested by WD Support, were you able to do that?

No, since the extended DLG test passed, I did not bother to do that,
especially since it required installing the software on my husbands PC (on
Windows 7) and he isn’t a fan of installing anything he doesn’t need on his
PC! :slight_smile:

Thanks for following up,