WD unlocker doesn’t recognise my password

I am having trouble accessing my WD Ultra passport for MAC. The reason I post this issue here is that I am hopping someone had a similar problem and was lucky enough to resolve it without erasing or formatting the drive.
Initially, on 10th of June 23, my security/unlocker wouldn’t recognise my password which was on auto, never had to insert it. I thought that I’ve changed it and forgot my WD Security/Unlocker password so I raised and incident with WD.
In the meantime , I looked here on the Forum and after hours of browsing I managed to follow someone’s instructions and rest the security password and it worked all the time until 24th of June 23 when the same think happened, my password was not recognised anymore.
I’ve reopened the initial incident and I was told:
“***We regret to inform you that WD unlocker is end-of-life software as an alternative you can use the WD security software application to allow password protection of external drives that support 256-bit AES hardware encryption from unauthorised use or access. The computer must be able to run .exe files.”
I’ve uninstall all the WD softwares (Discovery, Utility, security) and installed the WD security again. I tried everything, no success .
Now, I’ve learned the hard way that an extra drive should have a backup. I don’t have, so erasing the drive will mean loosing precious data, including all the evidences for my upcoming Diploma exam (16 months work).
I don’t have a spare laptop to connect my drive to. I can ask a friend but that will take time (my friends are far away).
My drive is under guarantee and I escalated the incident.
I’ve also contacted Apple support to make sure the laptop or any remaining WD roots are causing trouble. Apparently no issues with my laptop (MAC pro- Ventura 13.4.1)
I would really appreciate your advice. I am not a technical guru but i am trying my best

Hi @Rox,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Hello @Keerti_01 .

Thank you very much for offering to help. I did open a case and I followed their advice without success .It was a lengthy, stressful time :))
I managed somehow to unlock my WD passport. All I did different was to uninstall and install WD utilities, turn off WI-FI and tried to login into my WD unlocker. It worked.
The conclusion :

  • there was nothing wrong with my password , I haven’t reset it, it just worked again.
  • the WD unlocker and WD security didn’t recognised my password after installing Ventura. It was definitely a clash between the new software and WD.
    There is an opportunity for improvement WD can look into .
    For now, I learned the lesson and I will buy additional storage to back up data and avoid stressful situations like this .

Hi, I have quite the same problem…can you explain me how you resolved the problem please : I am desperate : since yesterday, my external hard drive my passport doesn’t unlock with the usual password. I didn’t change anything, no updates, nothing. It will not unlock. Then I ran WD unlock and first removed the password and changed the password ( proof that my password was right, otherwise I couldn’t have done these changes ) and WD Unlock says : “password changed”. But directly after that, the system asks again for a password to unlock passport. I put in the new password and nothing happens. How does it come ? I really need help as there are extremely important datas on the external drive…I hope someone can help ? regards, Pierre