MAC vault preventing access

#1

Hello,

I own a WD My Passport Ultra 1TB.

The drive unlocks after I enter in the password. I get to this point by clicking on WD Drive Unlock button that appears when I plug the device in.

As soon as the device unlocks, a popup screen with a photo of a vault appears and requests for the password again even though I’ve already entered it and unlocked the drive. I’ve tried all different possible passwords but it does not unlock. I cannot get past this point no matter what I’ve tried. I’ve tried to unlock this on a different computer but the same problem persists.

I’ve tried to update the firmware but the device isn’t recognized. I’m not sure if this relates to this problem.

I would really appreciate any input on this. I have a lot of priceless photos on this and it would be devastating to lose them.

Thanks

#2

It seems that there is a dual encryption on the device. Somehow, the drive is able to be unlocked by the WD Drive Unlocker, but it is not letting you to unlock the drive by using the password you setup for the encryption on Mac using File Vault.

If you remember the password, you can try entering the File Vault password you setup or you may Apple Support for such issue.

#3

I am having a similar problem here. The problem is that the Unlocker is not popping up. I looked at the WD file on Finder, and I didn’t see the Unlocker drive. Am I supposed to see it? Maybe something crazy happened an it was deleted??? I looked at reinstalling the unlocker driver, but everywhere I looked said that it’s installed automatically with the rest. I was wondering if I uninstall the software-drivers, and reinstall everything again if I will loose data… that can possibly happen right? My first bet is that the unlocked driver has problems…

#4

bump

#5

I’ve tried to unlock my hard drive on a Windows computer as well and a pop up display shows stating that the drive is unlocked after I enter the correct password. However, the drive is nowhere to be found.

Could this signal an issue with the hard drive itself instead of issues with the file vault on MAC?

#6

Any help would be greatly appreciated!