WD TV Youtube not working

Has anyone had this pop up on their Youtube screen? I tried resetting the box and everything but it’s still there. Help, please!

Yep! Same issue only started this morning . Reboot did nothing . Hopefully it’s just a temporary glitch.

Disconnected everything and let the player sit for 10 minutes then reconnected and youtube reappeared. Probably just a coincidence but good to have it back. :grinning:

Not working here either on the WDTV … (it’s working on my PS3, Android Box and Raspberry Pi 3)

WDTV was disconnected for several days
Tried a Factory Reset (from Setup Menu and Reset Hole) … Nope, No Youtube
Disconnected and waited for 10-15 min (as suggested above) … Still no Youtube

oh well, at least i have other devices to rely on for a working Youtube :slight_smile:

I have the same problem

Hello Joey, found the link. Mine stopped yesterday also.

Hello,

We have passed this long to support.

Same here.

Hello All,

Please make sure you are running the latest firmware on your device.

Version 1.03.07 for the WD TV Media Player
Version 2.03.20 for the WD TV Live Streaming Media Player

I have the latest firmware on my device. No effect.
That was the first I checked.

1 Like

Hi all,

I have the same problem - exactly the same screen as in the screenshot above appears. I use youtube everyday on wd tv. Yesterday it was still working, today not anymore. I checked the version: 2.03.20. Might be problem caused by youtube?

WD Support please solve this problem as soon as possible.

Ditto. Worked yesterday, does not work today, returns the “Sorry…” page shown above.

Firmware is up to date (2.03.20).

The URL http://www.youtube.com/tv works fine and loads the app in any browser I’ve tried on the same network. (That is still the url for the app for TV’s, yes?)

ETA: Posts about this on the YouTube help forum (it does seem to be something they’ve changed in the past couple of days, so likely worth reporting there)
https://productforums.google.com/forum/#!topic/youtube/K9KbvnwJhrY;context-place=forum/youtube

I think the problem is caused by YouTube.
They changed the App nearly everyday and imho it was getting worse and worse.
I hope that the problem can be solved by WD and Google because I used the App everyday.

I am running latest firmware 1.03.07

Hi,

I have been experiencing the same problem and get the same error screen as above.

The device is WDTV Live Streaming Media Player with latest firmware (2.03.20) connected to a home network. No changes have been made to the media device or the network. YouTube has been working fine
until this started to happen.

YouTube Leanback works fine on other devices connected to the same network.

In case this is a YouTube problem (and likely is…), it would be good to have as many posts as possible on the YouTube forum page for this issue here: https://productforums.google.com/forum/#!topic/youtube/K9KbvnwJhrY;context-place=forum/youtube

I have the same issue. It happened yesterday. I have been on the latest version of firmware 2.03.20 and no issues until yesterday. I love watching youtube. The screen is exactly as pictured above.
Did a factory reset but issue still there.

1 Like

Hi All, Suddenly my WD TV Media Player ( Firmware Vesion 1.03.07 - just recently updated ) stopped playing YouTube. everytime Open YouTube Leanback app saying “This page is not available. Sorry about that. Try searching for something else”

Does anyone have any solution?. I have seen lots of users they have the same issue in this forum.

If the latest firmware causing the problem, is there any way we can roll back to old firmware. I have downloaded the old firmware but the device does not give any option to install or roll back. does anyone know how to roll back the firmware?

If nothing resolve the issue then I have to return this device.

very disappointing service WD team. We spending money for your product but you are not providing the service.

1 Like

i do … EDIT it did solve the problem for me

I would blame Google / Youtube first before WD

https://productforums.google.com/forum/#!topic/youtube/K9KbvnwJhrY;context-place=forum/youtube

anyways, Youtube Leanback is working fine on my Playstation 3 and Android TV Box … it’s good to own a few devices in case one decides to … “play up” :wink:

Hi all,

If this will not be solved within reasonable time, I am going for another solution. I think the Amazon Fire Stick has youtube. Anyone any experience with the Amazon Stick? Has good recommendations on Amazon for sure.

will be interesting to see how long this takes to get resolved :neutral_face:

because if it requires a “new firmware” from WD to solve the problem … then a “reasonable time” flies out the window :wink: