WD TV Live sees ALL shared folders?

I created a new standard user on my PC called “WDTV” with a simple password (I use the Password Proctected sharing option under the Homegroup settings for  Windows 7).

Then shared my Media folder with only the Admin account (there by default) and the user “WDTV”. There are other shared folders on the system only shared with Admin user.

On WDTV, connected to network share and can see and browse ALL shares, not just the Media folder. The other shares are admin user only, not Everyone or the Homegroup setting.

Is there a way to prevent WDTV from seeing all the shared folders on my PC? Everything seems to be configured correctly but this seems to be a security lapse.

All I want the WDTV to see is the shared Media folder.


If it’s a security issue, it’s with your PC.

WDTV can’t “Force” a computer to allow unauthorized access.

By the way, Homegroups are not supported.  So any changes or setup you’re doing there are irrelevent to the WD.

Yes, I figured it was something to do with Windows. I think I might have fixed it by doing the following:

Navigate to Network > [shared folder - the one I don’t want visible to WDTV]

Right-click and view Properties

Click Sharing tab

Click Advanced Sharing

Select Permissions

Remove the “Everyone” group

Add the admin user.

Click Apply

So if I understood this correctly, despite having only added the “WDTV” user to one shared folder using the “Share with…” option, Windows made ALL shared folders visible to the WDTV. Even though the other shares were (supposedly) only shared with the “Admin” user.

But when you dig down to the actual sharing details, the default group with access permissions is “Everyone”. Nice one, Microsoft!