Blocking media shares and network drives from WD Live?

Just got my first WD Live Plus and very, very impressed. Unlike the Sony Box, networking is a brezze. In fact it might be too good as it seeks out every device in my homegroup, even if I don’t want it to access them.

Wondering if anyone has found a way to be able to hide / block certain media servers and network shares from showing up in the menus?

We use ours for our kids playroom and don’t want them having access to anything but the kids network share that we created for their movies / videos.

Thanks in advance!

Your best bet would be to password protect your other network storage devices.  They will still show up, but when someone without the password (aka your kids) tries to log in they will be asked for the password and won’t be able to see the contents.

Thanks for the quick response. 

2 questions:

  1. In my windows homegroup network, I have specific shares: ex: “Kids”, “Movies” and “Photos”. WD Live doesn’t show each specific share but instead the shared device. Any way to align with that (and password protect?)

  2. Any way to completely hide devices from the menus? We have so many Internet devices hooked up (ex: Directv dvr’s) that are detected as media devices BUT can’t stream conent that it’s confusing and unneccesary.


First off, don’t confuse the term HOMEGROUP.   There’s no such thing as far as the WDTV’s are concerned.

WDTV’s use WORKGROUPS.   The only thing that uses HOMEGROUPS are other WIn7 PCs.

  1.  No, it will list EVERY device in the workgroup (and sometimes OTHER workgroups) regardless of whether or not it can log into those devices.

  2. You’d have to look in the configs for those other boxes to see if you can disable DLNA / UPnP, assuming you’re not using them anyway.  If you can’t disable it from the other boxes, then they’ll continue to be displayed.   You can’t “hide” them on the WD’s.

i have noticed that when trying to access the network share if i left the username as anonymous and password blank it would not show any of the network shares  that i had shared using the admin account but only showed up the shares where i had given full control to all users. If you change the folder rights for the other shared folders and do not give rights to everyone and then try logging in from the WD box with the anonymous username it should show only the kids folders and not the rest. Hope this helps.

Thanks Silent - I’ll give it a try!