Wd tv live device can not connect to the network

I’m really confused-I have the wd tv live and a wd elements external drive-they used to see each other so that I could watch videos from the drive on my tv, but now when I try to get to the movies I get the message that the “Device could not connect to the network” I can’ t figure out why it needs to connect to the network since the drive is connected to the live box. Please help

Have you tried “turning it off and turning it on?” To turn the WDTV off, you need to unplug it, wait 10 seconds or so, and plug it back in. BUT, If the external drive has its own power supply, you need to remove power from it while the WDTV is off, Leave it off for a few seconds also, and plug it back in to power before turning on the WDTV. Once drive is spinning for a minute or so, THEN plug the WDTV back in to power. Unless something weird is going on, this ought to fix things.

Mine would do that sometimes. The WD TV would drop the network. If what Mike says doesn’t work. I usually had to go into Settings and restart the device from there.

How would I go about restarting it from Settings? I haven’t tried Mike’s suggestion yet, but not sure if I can get to Settings on the WDTV.

I’m not sure I follow Bill exactly,. He may mean resetting the device to factory defaults within the settings, which can clear a lot of problems, but can make new ones (like you have to set the WDTV from scratch again). and most people don’t know how to do that without aid of the user manual that can be downloaded from wdc.com Support.

If my suggestion doesn’t fix it, (but turning a gadget off and back on fixes lots of things,) so try it first. Let me know if it doesn’t help, and we can go from there.

Ok, so tried powering off and on like you said, but I still get the message “Device could not connect to the network”
I’m still wondering why it needs to connect to the network-I’ve never had the tv connected to internet and the WDTV and elements used to work just fine.

The firmware is 1.06.42_B is that what it should be?

I have 3 remotes and none of them will take me to a home screen-what’s up with that?

OK, too bad the easy fix did not work, but I have been working on the problem this morning for you. Thanks for telling me the firmware version. It appears the model WDTV you have is called the “WDTV Live Plus”. Can you confirm this is the case? If not, what IS the model name/number?

Some other questions for you:

Are you the person who originally set up the WDTV with drive?

Is it all in its original location? Meaning, it was not set up, and later moved to another location.

I am assuming the error message is coming from the WDTV, and not the drive, correct?

Is the WDTV connected to home network via a wired Ethernet cable or wirelessly? And, has it always been connected the same way to network?

The remote issue: I have no idea at this point. Are all three the exact same remote; i.e. they look the same? (Why three remotes?)

From what I have learned, the error message comes from the WDTV, and not the drive. The error message indicates the WDTV is not connected to the home network either by wire or wireless,

Awaiting your reply.

1 Like

No, I didn’t originally set it up
Yes it is in it’s original location
Yes, coming from WTV
No-not connected to network by ethernet or wired or wireless
Yes, remotes are all the same )I have 3 different WDTV’s none of them recognize the drive

I believe I have your problem solved.

We have the same model WDTV, and I reproduced your problem by disconnecting the Ethernet network cable to my WDTV. I suspected you were not going into the correct access point of the WDTV, so after selecting Video, I went into “Local drives”, “Folders” and all went well to select a movie, but if I went into “Media server” or “Network shares” I got same error message as you received. (Both of these choices require being connected to a home network, and I had just disconnected it, so, of course, it would fail with the resultant error message.)
Only go into Local drives to see media on the attached drive(s). The other two choices are only used if looking for media on the network if you have a network connected to WDTV.

So here is what to do:
From WDTV Main Menu, go into Video, select “Local drives”, select “Folders”, select the drive, select your movie collection and watch a movie!

If you also have music or photos on the attached drive, it is the same basic procedure; select Music or Photo, then select Folders, Local drives, and enjoy.


Thanks @mike27oct for helping her out. I didn’t realize she had a live plus. The UI is different than the newer WD TV.

Sure, Bill. I hope she comes back for her solution which took a few posts between us for me to figure out.


Were you able to find your files to play them?

Unfortunately, no-the advice you gave is in fact what I have been doing, but it still says I cannot connect with the network. I’m lost.

Carol, did the solution I gave you regarding the menu items work?

You have other WDTVs you say; have you checked them and do they have the same network error issue?

Does each WDTV have its own drive attached to it?

BTW, Since your WDTVs are not (purposely) connected to the network, none of the drives can access the Elements drive on the unit we have been talking about.

Carol, I thought of other questions for you. Is the Elements drive directly connected to the WDTV with a USB cable? Is the drive plugged into power, and is there some sort of light on it lit to indicate it has power to it? Can you hear the drive spinning quietly?

You really should not have an issue regarding network error messages if drive is directly connected to WDTV. The only thing I can think of that causes network error messages like yours is if a device is supposed to be connected to a network, but it isn’t.

1 Like

You were good here, mike. Yet, yet - it looks as if she’s gone away - aaawww!

Thanks, I believe you are correct. We see this happen too often. I even sent her a PM. I could try one more time.

1 Like

I wouldn’t want you to think your typically excellent responses are anything but that. They are valued.
In this case so much wasn’t stated and it seemed to me Carol maybe wasn’t aware of what networks are, via a router, so I thought it was particularly admirable and brave of you to offer to help. It’s sad to see so many threads perishing here sometimes, for the sake of someone offering help.