WD TV freezing all over the world: List of solutions


#1

Hello friends

in the last few weeks I have found at least a dozen of posts with users talking about the same problem:
The image freezes while playing a video and the devides does not respond to the remote.

the solutions given in all theses posts the can be summarized in the following:

1 “Rollback to the earlier version of the software”. Say goodbye to p2p downloads, Miracast, Grid themes…

This seems to work in most cases but not in all. In my case this “solved” the problem

2 “Disconnect the device from de internet network”. This option disables most of the features we bought the device for in the first place.

3.- “Disable the WiDi (wireless display or miracast) in the network settings (wifi direct)”. I tried this one and it didn`t work

4.- “Set manually dns 127.0.0.1 in the network settings of the WDTV. This is a special IP address, that refers to your WDTV.
This prevents the WDTV to go to the internet.
So now you can playback without any block all files over your nas (in your internal network) or usb drives.”
I have not tried this solution.

Does anyone know of another solution? Please let us know in this thread.

WD releasing a new version of firmware to correct a bug which affects a high number of devices? I hope so.


Cause Freezing found! WD, PLEASE PUT THIS SITE BACK ON LINE ASAP!
WDTV Live G3 suddenly started behaving weirdly
WDTV Live G3 suddenly started behaving weirdly
WD TV blocage de lecture d'un film
#2

The solution 4 is a good idea, anyone is willing to try it? (I don’t want to rollback to the latest firmware just to test it)


#3

Solution 4 is the only one I haven’t tried and like Matrix19 I would like to know if there’s a possibility that it does work, Solution 1 was the only one that worked for me so now on the previous firmware…


#4

I found the solution to the problem of freezing .i have marantz NR106 receiver,Sony 40X3500Lcd Tv.
Close the lipsync feature on tv,and receiver to solve the freezing problem in Western Digital


#5

I experienced the same problems. Turning off Wifi Direct (and hence Miracast), auto updates and homephone seemed to solve it.


#6

I don´t know what “homephone” is


#7

The feedback connection to WD. You can turn that on or off in your settings.


#8

I tried all of those with no luck, the only thing worked for me was rolling back.


#9

I’ve been having this issue and the problems were only increasing. The breaking point for me was 4 freezes during the course of one movie.

I looked around and found this. I didn’t try option 1. Option 2 isn’t really an option for me, since I need it networked. Option 3 was already done. I gave option 4 a shot and – knock on wood – it seems to have solved the issue. No freeze since I changed to 127.0.0.1.

Now, I’m not sure what exactly changing the DNS does. I’m under the interpretation from the explanation above that it effectively prevents the box from getting online, but keeps network functionality. This is what I’m after; the box, for me, is just a way to play all my media files from my server on my TV. So this seems to be working (knock on wood again).

Now, option 1, to me, is not an acceptable solution. I started a thread a while back about the “network share” issue, and that was resolved with the latest firmware. I’d had virtually no issues since then. Only recently have the freezes occurred, and that tells me this isn’t a firmware issue. If it were, the problems would be there from day one. Something else was going on, and the fact that the issue disappeared when I didn’t let the box get to the internet tells me it’s something on that end. My theory is that it was sending or receiving something often and that process is no longer working. So the rollback, for me, is not a solution, since I’ll just go back to my old problems. It seems like this box from hell is back to its old tricks.


#10

I use my WDTV mainly for Spotify and streaming movies from the Internal hard disk from my PC. (Windows file sharing)
So I can’t disconnect from Internet, since I need Internet for Spotify and rolling back causes problems with file-sharing…


#11

If you can you ought to give Linux shares a shot if you have network problems with the previous firmware. My NAS has them built in and I installed haneWin NFS server on my windows PC which works fine. No problems with network since then.


#12

I’m afraid my digital skills are not as good as that… :frowning:


#13

what about installing serviio on the box (pc) with the files. wdtv is good at streaming from serviio. so no file sharing karfufull.


#14

Wow thank you for the test… I think I will try to flash the latest firmware on one of my 2 devices and test the DNS trick


#15

When will this problem be solved? Can not watch anything without it freezes.


#16

I tried option 4 (DNS 127.0.0.1). It seemed to fix the problem on both of my devices …for 2 days. Now both G3 devices have ground to a near-stop again.

Any network experts out there can correct me, but wouldn’t specifying a DNS of 127.0.0.1 still allow the box to directly reach any IP addresses hardcoded in it?

Anyway, my next experiment will be to block internet access by the WDTV at the router, and see what that does.


#17

Yes, if the box try to reach an IP adress, it will works, but it won’t resolve any hostname.


#18

Over the last month or so I have been having a similar problem but mainly with netflix - although I have seen it with playing from a local disk as well.
The box stops working so I power cycle then it will play for 10-15 minutes then it will crash again (using netflix) repeat 4 - 6 times. Next day I can watch a 2 hour film on netflix no problem. Next day I get the crashes again.
Up until a month or so ago it never crashed

I have just turned off miracast and I have set the music and video to local disk (it was set to point to tversity) - I’ll see what happens


#19

Hello to everybody, i disconnected the WiFi, autoupdate and the homephone and it worked !!! No crash for 2 Days !

Greetinx from Germany
Thomas


#20

Rolling back to Firmware 2.01.86 (from 2.02.32) solved the freezing problem for me. At least it hasn’t freezed or acted up for over a week now!