Did disable Wifi Direct (Miracast) solve your freezing problems?

Ok, I use my WDTV Live mainly for streaming Spotify and streaming movies with Windows filesharing. I stream movies from the harddisk from my Windows 8.2 PC which is connected with a LAN cable to my modem. My modem is also hardwired to my WD.
I use the latest software upgrade from WD.
As everybody else around the world, my WD suddenly started to freeze a few weeks ago and did not response to the remote. I had to power recycle it to get started again, after which it froze again after playing for 15 minutes or so.

I changed my settings: by disabling Wifi Direct, homephone and automatic software updates.

I tried this for a week, and it only came back once with the freezing problems. This was after I did a LOT of actions in Spotify, like searching, adding, deleting and so on. After powercycling, Spotify didn’t find my playlists and favorites any more, I had to powercycle the WDTV many times and in the end they were finally there again. I am not sure if this is a new problem or it just happened by coincidence.

Yesterday I streamed, paused (re)played movies for hours, without freezing up. Spotify keeps on playing for hours.

It seems to me that disabling Wifi Direct and the other settings as mentioned helps a lot in the freezing problem!

Did any one else try to disable Wifi Direct and did that help also?


Ad (The Netherlands)

In my case it didn´t work. I had to rollback the firmware

Didn’t work for me either.

I’ve been getting variable results. However, much of the time the unit’s been working properly again, with the occasional freeze that takes a couple of power cycles to fix (the indicator seems to be whether or not the services disappear. If I have a full front page, then we’re good to go.)

The freeze and non-response to the remote is quite random.

Hello, in my case it worked. My WD ran about 4 Hours without freezing until today. I disconnected the WiFi, the homephone and the autoupdate.

Greetinx from Germany

Still getting variable results, but the freezing is back full-on, along with the vanishing services. I’ve rolled back the firmware yet again, and might just leave it as it is pending the purchase of an alternative.

I have disabled the settings mentioned. But the only thing that worked for me was rolling back FW. Rolling back to Firmware 2.01.86 (from 2.02.32) solved the freezing problem for me. At least it hasn’t freezed or acted up for over a week now!

No, disabling wifi direct didn’t help, neither did turning off the firmware check, nor did turning off media server. The only thing that worked was rolling back to the previous firmware and it has worked now for over a week without freezing.