WD Sync

In fact, I’m so confused about all the programs that you guys have!!

Let me tell you about my WD first. I have the WD Passport Elite, and I used it on one compute (PC)r, installed all the programs (WD Sync, WD Anywhere Backup, MioNet blah blah blah) and it didn’t work! So I just manually dragged all the folders onto the WD, like the programs didn’t exist. I changed computers (still PC) and I tried to install all the programs again, now sometimes it tells me the installation for WD Anywhere Backup cannot be found/can’t be completed, WD_Sync.exe cannot be found. WHAT IS THIS?! 

So yesterday, I got really fed up, and installed WD Sync again. Yay, it worked… for the most part. I had to click on it many times, because most of the time, the thing crashed. Good job, WD Sync. I managed to successfully sync whatever I needed to sync on my WD using WD Sync, now here’s the question: How do I retrieve the files in my WD!? I searched the whole drive and I can’t find any of the files! I assume I would be able to view the files like how I would be able to if I dragged the same folders into the WD without using WD Sync. Unless WD Sync changes the format of my files, and only the computer recognizes it if and when I need to restore them… That would be stupid.

If someone could help me, I would be eternally grateful!! Thanks :slight_smile:

Be aware that the WD Sync is not a backup application, and yes it changes the extension of the file. Also, the WD Sync does not work well with 64 BIT OS, neither works with Windows 7.

Now, look here, this might help you:


I have used the Western Digital Passport (120 GB External drive) to sync up my Dell Dimension 4400 hard disk (also a Western Digital). Unfortunately, as it seems now, I have used the “Sync” option to get all the data on the external hard drive. My Dell Dimension hard disk drive got corrupted, and I am not able to use it as a secondary drive as well to retrive the data, the system is not recognising it during bootup. My only option is to use the synchronized data in the external drive to retrieve the data. However, when I try to sync the data (from the external HD) into the new internal HD, I get an error message saying that the disks not match (not the same disk where I had synced the data from). Is there any way I can work around this? Would appreciate any help.

I had contacted Western Digital as well, they say that the SyncData function should not be used as a backup mechanism.

Hi. I had a related question about WD sync, and have been scanning through the community posts to resolve my hard drive problems.

I read somewhere as well that WD sync is not supoosed to be for back-up. Why is that and what is it meant for? Because that is seriously the only program i have from my Hard Drive (which i got 2.5 years ago). When I open the VCD (or my hard drive), i do not see any of the other programs you guys talk about (or setup files for that matter).

So I was wondering: do you recommend I wipe/zero my “my essential passport” and then just install WD SmartWare to back up my files? My goal is just to have my WD up and running again because I am anticipating a computer crash.

Right now, whenever i try to open WD Sync I get a windows error saying it is closing the program (before opening) and if I try to reinstall and click on the setup.exe file, i get a message saying “corrupt file”.

I attempted to just update my harddrive so I could install WD SmartWare, but I think it does not work (keeps telling me to remove all USB and just connect my hard drive) because I used to have a password on it, and you are supposed to remove/disable it for the update. But I CAN’T get into my WD options to begin with!

Just thought i might interject since I have had this problem for a while, and no one seems to have heard of a similar issue. I suppose using WD Sync may have screwed things up. Thanks!

P.S. I had thought about “reinstalling” WD Sync as well. But there isn’t even an uninstall option (at least from my WD folders on my pc and in my hard drive). So even if the install option is screwed up, I can’t even properly remove the program. This just seems really odd to me too…