WD SYNC error with My Cloud EX 2 : could not verify firmware version

Hello there,

I used to be able to sync folders with EX2 but it does not work any longer.

I indeed upgrade MACOS to High Sierra and reinstall everything but when I try to install WD Sync I relentlessly get the error message: “WD Sync could not verify firmware version…” and I obviously cannot get through the installation.

For what is worth, BEFORE upgrading to high sierra I deleted the WDSync folder on my EX2 (I had emptied it anyway). Should anyone have a clue about what’s happening, I’d be grateful for any help!

Thanks a lot!

Hi jCris,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.