WD SSD Dashboard 2.2.0.1 Not Detecting WD SSD

Hi,

I just go WD Blue SSD. It works fine, but I can’t seem to get the WD SSD Dashboard to work. I have Win10_64pro. I tried re-installing it several times and rescan the system many time, it still saying: WD SSD Not Detected. I saw some post that Version 1 is working straight away, I am wondering why v2 is still having issue.

Thanks,
Ti.

I have the same issue with mine, on Windows 10 Pro x64 as well.

Drive works fine (it’s my boot drive © and the drive where Win 10 is installed), but Dashboard won’t detect it at all.

I have opened a case with WD about it yesterday, but no news from them yet.

Just found version 1.4.4.5 here: https://www.touslesdrivers.com/index.php?v_page=23&v_code=51127

When selecting the download server, DO NOT choose download.wdc.com, as it will give you the latest version instead (the one that doesn’t work).

I installed it, and it works fine. Will keep watching for a fix to the latest version, and hopefully for a response to my support case that I opened with WD.

1 Like

Thanks for the link. I got the file. Really appreciate it. I am not sure if WD is monitoring the Community too. Hope they will fix the issue quickly, it doesn’t look right otherwise.

Same issue here. Purchased 1 TB SSD. Cloned Drive. All is working great. Loaded WD SSD Dashboard. Doesn’t see the drive. Tried several times. Reboot system. Nothing. WD you need to fix this. Bought a Crucial SSD recently for my laptop and their SSD Dashboard software works perfect.

I wouldn’t install that version. Sketchy website. Downloading this trigged my antivirus program and quarantined the file.

Hi!

Must be a false positive from your antivirus software.

Been using it here for months, with no issues whatsoever.

Cheers!