My newly bought WD SSD not showing up in WD Dashboard

Hi. WD Dashboard not detecting my WD Green 120gb SSD. Im using windows 8.1. Don’t want to go to Windows 10. All things are updated. Tried most ways like, updating all kind of drivers(ahci, motherboard), restart, downgrading dashboard, etc. I just want to check and update my firmware if if dashboard works. Any solution of making it work or any other way to check and update firmware?
edit: crystal diskinfo detects it better, my current firmware from crystal diskinfo is T0910A0. why wd dashboard does not detect it but other every single software detect it fine?
if anyone using wd green 120gb ssd, please check this is latest T0910A0 firmware or not? if updates available, please can you send me firmware so i can flash using usb drive?

knuckle under and upgrade

didn’t understand? dashboard dont detect my ssd. tried all driver updating.

also ive tried every other software, every one of them detects wd ssd 120gb. and firmware T0910A0. its bad that the official software cant detect it but every other software detects it fine.

does not work on windows 10 too.