WD software not recognizing Passport

Hi, My computer seems to be recognizing that the hard drive is connected but the soft ware says to attach a supported device.

What software? and what model of Passport?

WD Discovery, WD Backup and/or WD Utilities. My Passport WD Im using Windows. I can’t get the software to recognize the hardware and vice versa. My backup keeps either saying “preparing backup” and/or 0 of 230 gigs backed up. My Passport is constantly flashing right now … because it’s trying to back up there?

It just finished and says, 0 of 230 gigs backed up! This is the first time using it and it came with just the box and some tiney=printed, in dif languages jargon that has nothing to do with setting up!

I bought a Lenovo laptop to give to a friend, plus a 1 terabyte My Passport with no software or guide. Lenovo is Windows 10. Downloaded software from your site WD discovery, etc., twice. The software does NOT recognize the drive at all. Please help, this is very frustrating.


My Lenovo Win 10 laptop worked fine with the WD Smartware Pro backup software. Any other WD software never worked. Now I replaced the drive and installed a new SSD and new Windows 10 so needed to install WD backup software to start new backups. The backup on the external drive did not want to open at all aat first. It said that I needed administrator rights and I clicked continue. It then started to open and the green bar at the top of a Window creeps along very slowly as it recognizes the files in the WD backup. I was finally able to see them easy with r/click and run as administrator. Then I needed to install something to a new WD drive to start backing up again. The SmartWare Pro is "no longer supported’ and I cannot find a link to download it. I finally stumbled on the regular WD Smartware and downloaded that. I am hoping to have better luck than with the WD Backup software. That is the newest current software and it is barebones . It offers few options. A backup schedule always needs to be made at setup and the best is continuous backup. That is not even an option with the currrent WD Backup so I tried checking every hour. I allowed it to run all last night and all day today and at the end had error messages and nothing was backed up at all. I recommend taking your chances with the 2018 smartware backup and skipping the WD Backup software. The one problem that often causes this is poorly fitting cables for the connection of the drive to the computer. I have found none better than the ones I can buy here. They do wear out. The G-Tech connections are a problem because the port on the drive itself is a little too big for the cable on that end so it disconnects and reconects and that makes a mess.