WD Backup Fails To Recognize Passport

I’ve been using an old 1 TB Passport using WD SmartWare for many years with few problems. I’ve just purchased a new 3 TB Passport. I’ve renamed the two Passports so they’re different. The new passport will accept files transferred from the old one. I’ve run a ‘Drive Status Check’ which the new drive passed. I’ve downloaded the newest WD Backup program (which fails to appear on the ‘All Programs’ list. Upon installing the new WD Backup program, when it automatically asks “Select You WD Storage Device…” I get “No Backup Targets Found. Rescan” which fails to find the new drive (which appears under “Computer”. I have not removed WD Smartware (which, BTW, is what opens when I open WD Discovery but which was only installed with the new drive). Is that a conflict? Please advise.

1 Like

Hi,

  1. WD Backup will not appear in any list except as an app on WD Discovery. It is not an executable program. The initial WD Backup is a setup activity.

  2. WD Backup, Wd Drive Utilities, WD Security, and WD Smartware should all appear as Apps in the WD Discovery.

  3. All Drives (or partitions} should appear in the WD Discovery Devices list with the amount of Available space.

  4. Your new drive may not be recognized for several reasons: A. Bad USB connection, B. USB connection through a hub, C Windows 10 problem, D. and others. Look through WD Knowledge Base for Passport troubleshooting.

I hope this helps.

Cliff

Please see below:

*N**OTE: This is a prior message, rejected due to containing more than
two images, now sent in parts.

*N**OTE: This is a prior message, rejected due to containing more than
two images, now sent in parts.

*N**OTE: This is a prior message, rejected due to containing more than
two images, now sent in parts.

Hi,

Did you download WD Backup and WD Security? I know it sounds screwy, but you do need to download them.

Also I think your new Passport is not being recognized because it has the same name as the older one. Try renaming using Disk Management. Select the drive and then Properties.

Cliff

Hi Clifford,

I may not have downloaded them from the site previously, but have done
so and installed them. The new Passport had been renamed to
differentiate if from the prior one, but I renamed it “New Passport - 3
TB” just to re-cover that base.

Note: WD security DID install correctly, but WD Backup DOES NOT appear
in “Aps” (was installed before ‘Security’ ap):

Hi Clifford,

Additional observation… WD Backup is not listed on program list
I
n
*“Start” menu, nor on list of removable programs on my
RevoUninstaller program, although W
D Securityis listed on both;
FWIW.*

Rael

Rael,
I think the problem now is that you did not complete the initial WD setup, as I recall. Not certain, but I think the WD setup does an initial Backup which allows you to select the drive and initializes WD Discovery to provide the WD BAckup selection. If you can find a way to get the WD setup, I think that will get you running. There is a download called WD Backup. It does NOT create a " WD Backup.exe", but it might give you the initial setup.

Below is the list of programs I have. I think you need them all.

WD programs

If this doesn’t help, I suggest you try WD Support and open support case, because I’m as far as I can go.

Good Luck, and please let me know.

Cliff

Clifford,
I did that when I got the drive initially. You’ll note in the attached image, that under “I:\WD Software Offline Installers\For Windows\WD Backup” there’s an “Install WD Backup.exe”, which when run loads the “WD Backup setup” program which, when “Select your WD storage device…” gives the “No backup targets found” notice despite the device appearing on the “Discovery” devices list. In other words, the backup program can’t find the device it’s running from!

As to you list of programs, is SmartWare supposed to be on it? The set-up for WD Backup says it’s different than SmartWare and the two don’t relate to each other.
I see a file on my 3 TB drive under “I:\WD Software Offline Installers\For Windows\WD Backup\redist”.
“redist” is an executable file that I’ve not run (unless it runs with the backup.exe file automatically). Should I run it? What does it do?
Rael

Hi Rael,

WD Smartware still runs fine independent of WD Backup, but I don’t use it anymore. Not supported by WD.

I:\WD Software Offline Installers\For Windows\WD Backup\redist”. sounds good to me. I can’t find it on my drive, but it may have gotten wiped off when the initial setup worked. Why not give it a try?

Cliff

Cliff,
‘redist’ is a file that loads a ‘.net’ or ‘dotnet’ program which, when executed advised me I already had a newer versions installed… its an MS web installer framework.

As I read the Passport manual I see that “Backup” is supposed to be one of the installed aps; it’s wasn’t and isn’t.
If I was to wipe the drive using the ‘drive erase’ function in the utilities ap, is there a single file I could download & install to return the drive to ‘stock’ condition since downloading individual files, judging from the lack of benefit of downloading ‘backup’ alone, seems inadequate.
BTW, ‘SmartWare’ shows up on my Discovery Aps list although it’s not supposed to be a part of WD Discovery.
Rael

Rael,

Nowhere in my WD program files can I find a WD Backup.exe file, yet it works.The closes I have is:

WDBackupPlugin.dll and WDBackupPlugin.dll.config in WD App Manager > Plugins > WD Backup. I’m not a programmer, so they are not too meaning full to me.

Smartware is still useable, so it is part of WD Discovery.

I can’t seem to help you any further. I have to suggest you go to WD Support and open a case.

I hope you can get this working,
Cliff

Thanks Cliff,
I’m tired of working with it. I’ll send it back to Best Buy as ‘defective’.
Perhaps order a new one direct from WD (although I can’t imagine why it would be any better), or try another brand.
Thanks for you help.
Rael

Your Welcome

I have a similar issue WD Backup can see my old Passport Drive but not my new one
it appears in windows and WD Drive utilities but cannot be discovered in WD Backup

This from my notes in April '18:

“The technician with whom I spoke was professional & knowledgeable but was unable to solve my issue because WD hasn’t provided a ‘fix’ for the problem they know exists in WD Discovery; i.e.; that WD Backup won’t install in some cases (associated with the failure to install ‘WD Backup helper’). That WD knows about this is demonstrated by the fact that there’s a “WD Backup Does Not See My Drive” customer help page (so, WD knows the issues exists, but cannot/will not fix it) and by the fact that WD Discovery Apps includes an ad & link to a special WD version of Acronis Backup which wouldn’t be present if WD didn’t know that WD Backup won’t work in an unknown number of cases. This qualifies as ‘bait & switch’.”

BTW: In an attempt to salvage something I purchased & installed the recommended Acronis Backup program… utter disaster compared to simplicity of WD Smartware. Ended up using newly purchased 3 TB passport as standard peripheral hard drive & am running unsupported version of WDSmartware to my old 1 TB passport without problems.

Good luck…

Thank you for your hard work on this problem, Rael_Nidess! I am stuck like you and I will see what WD support says.