WD SmartWare Pro unable to find WD MyCloud in my network

I am trying to get SmartWare Pro to do backups to my MyCloud unit, but it is unable to find it. I only see the dropbox option.

  • I have upgraded to SmartWare Pro version 2.4.14
  • I have downloaded WD Discovery and it immediately finds the MyCloud unit
  • Other WD MyCloud software finds it too, and I can reach it from the browser on
  • However, SmartWare Pro simply cannot find it at all4
  • It worked find on my previous laptop, for several months, but not on this brand new laptop running Win10

I have spent four hours now in your forums and testing various things with no result. So what do I do?
Right now I am not backing up my laptop, and I hate it…


Do they both have the same Work Group name, Laptop and My Cloud? Do they both show up as being on your network? Have you checked the SmartWare User Manual?


Thanks for your effort to help.
They are both in work group WORKGROUP.
They both show up in our network.
It still doesn’t work.
I find no additional information in the user manual.
I have no backup.
The WD drive is totally useless at this point.

The WD My Cloud is not totally useless. It can still be used to store a backup using any third party backup software that supports saving to an NAS. Windows 10 can be a bit flaky with the My Cloud as explained in the Compilation of Windows 10 Methods, Steps and Solutions thread tacked at the top of this subforum. I’ve had similar problems with Windows 7 were Smartware sometimes has trouble finding the My Cloud or accessing the Smartware folder when it is set to Private via the Dashboard. My solution was to dump Smartware and use a more full featured third party backup program/software.

But if the product I have purchased doesn’t work at all, then it is useless to me.
I do not intend to start looking for third party software so that I get a combination that none ever will support if I run into problems.
If they don’t get it to work for me, they will have to refund me.

Thanks for the link to the Windows 10 resource. Will look into that.

It should be noted the product you purchased was the WD My Cloud, not WD Smartware. The Smartware software is something that is included free with the WD My Cloud just like the other WD software used to access the My Cloud (including remote software). For some that included free software works, for others it doesn’t or they have certain problems with it. That however doesn’t mean the My Cloud doesn’t work, only that the WD included software used to access or save content to it doesn’t work (or doesn’t work properly).

If you haven’t already done so you may want to read the Smartware User Manual to see if there is anything in there that is of use.

I prefer to use a full featured backup software (Acronis) that allows me to create emergency recovery media that can be used to restore the backed up content without having to reinstall the Windows OS then install Smartware. The Acronis software I use is not free, but there are several free backup programs out there that may work better and have more features than Smartware. Here are a couple of free backup programs:

Macrium Reflect Free Edition
Paragon Backup & Recovery Free Edition
EaseUS Todo Backup Free

It is marked with the functionality provided with the (free) software so at least according to swedish consumer law, they need to get it to work or they will have to refund it.
Now, I AM a techie so had this been a couple of years ago I would have connected a linux box and analyzed this down to atoms and bits. However, these days my time is too precious so I chose not to. I just want it to work.
However, I don’t want to process this. I just want it to work.
It worked like a charm on my previous laptop which also had Win10 and it is so weird that it doesn’t work on this laptop.
Now, I have created a formal support case with WD, so I am sure I will be able to post a solution here in a few days…

But if the product I have purchased doesn’t work at all, then it is useless to me.

Yes: take your Windows 10 laptop back to the shop; it doesn’t work properly…

If the My Cloud and the Smartware software worked on a previous laptop with Windows 10 but not on your current one running Windows 10, then that indicates a problem with your computer (probably with Windows 10) and not necessarily with Smartware or the My Cloud.

Microsoft caused problem with My Cloud usage with their November Windows 10 update.