WD Shared Space

HELLP!!! The WD Discovery Software finds the device, however whan I click on the configure button, the web page that opens just says Internet Explorer cannot display the web page. I have tried to rest and hard reset to no avail. Any ideas?

Have you tried directly without WDDiscover?

I mean: what happens when you type in the IP address of your box directly into your browser?

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Hmm, this happens when your computer can’t determine the drive’s IP address properly, usually due to firewall issues.  Unfortunately, you left a lot of detail out of your post, so I can only give some general advice.  For specific advice, contact our technical support, and of course I’ll reply here if you need it.

The quickest thing to do is check your router and see if you can find the ShareSpace’s IP address.  Sometimes routers will have a link that says “show connected device list” or sometimes they have a link to display your “DHCP table”.

If the router doesn’t show a device called “WDShareSpace” then you can use the MAC address on the barcode on the back of your ShareSpace to match the IP address listed in your router.  Simply type this IP address into your Web browser’s address bar and press Enter.  That should take you to the Network Storage Manager login for your WD ShareSpace.  Check out the User Manual for all the fun details, but “admin” and “admin” are the default username and password–no quotes.

WD ShareSpace documentation: