WD sent me a faulty WD 4TB RED replacement HDD

Hi,

Last week my MyCloudEx2 Ultra flagged up a BAD drive 1 in my RAID 1 set up, saying that it was degraded. I tried on a number of occasions to auto rebuild the RAID but everytime. I kept getting error massage within SMART DATA saying the drive was either BAD or the RAID 1 was degraded.

Just to make you aware of the set up: I have two 4TB WD Red drives. The failed drive was manufactured on 16th Februaray 2016, so still under warranty

I then raised a RMA with WD support portal and returned faulty drive on Monday. I received replacement HDD this afternoon, so I placed drive into Bay 1 and proceeded to auto rebuild raid, and found to my horror that the drive WD sent me seems to be faulty also, as I’m getting the messages within McCloud RAID profile that volume is Degraded and when I look within Disk status its says Drive 1 is BAD.

To say I’m annoyed is an understatement as I’m NOW going to have to raise another RMA to return this drive as well as being out of pocket again as I’m then going to have to pay for recorded postage twice to return back to them when it was WD that sent me the faulty HDD in the 1st place.

Has anyone else had a similar situation when returning a faulty HDD or have I just been very unlucky in this instance.

Thanks

It’s also possible that the raid inside the case is failed. I would set up a call back with WD to determine whether that’s the case. In the meantime, I would make sure you have your data backed up.

Hi Bill,

Thanks for the reply. I have just switched the drives in my WD NAS to see if the problem moves with the drive, So I moved the healthy drive2 into slot 1 and the faulty drive1 into slot 2 I then re-tried an auto rebuild and it made an attempt to rebuild then it failed with the message Degraded. So the problem seems to move with the drive by the looks of it. I hope that helps. I’m new to RAID set ups, so when you say that the raid inside the case can fail, I’m not sure how to check this.

I’m not sure whether this is a coincidence or not, but my original good drive seemed to fail not long after I updated to the latest firmware.

Thanks

@dswv42
You still have hardware in the case. That’s what my concern was.

@Floyd73
Yeah, I would definitely set up a call with support and let them take you through their steps. And, at the same time, you can bring up your concern about the latest firmware.

Hi chaps - I very much appreciate your help on resolving this issue. I decided to hook up the 4tb HDD to my windows 10 desktop via a winstars Sata hard drive USB docking station and was going to test the drive via either piriform or crystalmarks and unfortunately after powering on the drive, it spun away for a good number of minutes before Windows even recognized there was a HDD… It had taken a good 5 minutes or so before the drive even showed up within Windows disk management. I cant seem to access the drive for testing either. I even tried a quick format and got an error message back from virtual disk manager “The format did not complete successfully” and there is a constant noise coming from drive, almost as if the platters are rubbing again one and other.

I think its now safe to assume that WD have indeed sent me a faulty replacement HDD.

What do I now do in order to return faulty HDD as I don’t see why I should have to pay for postage twice. As I feel WD should supply me with a prepaid RMA in this instance since this was not my fault.

Thanks again.

I received a phone call out of the blue from a lady by the name of [Deleted] from WD Support on Friday 21st asking for the serial number of the fault drive, so that they could send me a UPS prepaid label.

I thought perfect, some one from WD is monitoring these forums and decided to contact me direct and correct this issue.

Unfortunately. I forwarded on the serial number to the email address [Deleted] sent me late Friday afternoon and I still haven’t received my UPS label.

I have contacted WD support on a number of occasions asking where my label is and no one has bothered to reply to my emails.

This is getting ridiculous…PLEASE…PLEASE…PLEASE help me out here. All I ask, is for a prepaid label so that I can return the faulty drive and get a replacement.

Right now I only have one drive in my WD cloud NAS with no back up. If this drive fails then I’m really stuffed.

I have spent a small fortune on WD drives and WD NAS servers of late. I had chosen WD as I believed WD to be a world leading storage provider with excellent customer service and to say that I’m disappointed with the service provided is an understatement.

This is the email case number:

[Deleted]

Thanks

Did you check your spam folders for the email? Also, it may be a link in an email to print from. I’m also looking into this.

Hi Bill_S ,

Yes, I do check my spam folder regularly as some genuine emails in the past have made their way to my spam folder, so I check it as a matter of course now.

The original email from WD support just asked me to supply the serial number of faulty drive, which I have done. There was no link to print from.

Here are some of the contents of the email:

Thank you for contacting Western Digital Customer Service and Support.

Further to our telephone conversation, kindly please provide us with the Serial Number of the faulty replacement drive in order to arrange for a UPS label to be sent out to you.

Again we apologize for any inconvenience you have encountered and appreciate your kind cooperation.

If you have any further questions, please reply to this email and we will be happy to assist you further.

hi dswv42 - Thanks for sharing your experience. Not exactly a ringing endorsement of WD.

This is now day 7 since I last had any communications from WD support who stated that they were going to send me a prepaid UPS label, still waiting for this RMA label.

This is getting ridiculous…Please someone take the initiative and resolve this for me.

Thanks

Just a wee update. I eventually got my free prepaid UPS label about 13 days ago. I then sent off the faulty drive and I finally received a replacement re certified 4TB HDD last Wed/Thurs and I’m happy to report that the drive was fine and I managed to rebuild the RAID.

We got there eventually but I would NOT want to repeat this process again as it was made more difficult than it needed being.

I am also having a bad situation… I had 4 disks in an old system (warranty good until 2019). I got myself a new NAS and it detected 3 of the 4 drive as “abnormal”. I proceeded to create RMA. After creating 2 “Advanced” RMA, it would not let me create the third one. After double checking everything, I noticed that WD had “blocked” not one, not 2 fees but 5 fees of 80$ On my credit card. Plus, the second RMA was registered as “Standard” and they charged me an extra 80$ to convert the Standard RMA to Advanced. I am now up to 7x 80$ on my credit card. Today, I received the first drive and when I tried to build my Raid 1, my NAS marked the new disk as abnormal as there are over 46000 bad sectors on it… This whole thing is completly ridiculous and no one at WD seems able to help me. I will call again tomorrow but It feels like this is far from over :frowning: