Drive Status Fault - Help Please!

Hello, I have a WD EX4 with 4 3TB WD Red drives set up in a RAID 5. This is my first experience with this type of device and had previously been using individual external hard drives. It has been working without issue for the past few years and I noticed today that it has a red light over drive 1. When I cycle through the display on the front of the unit, I see a “Drive Status: Fault.” On the web browser page, the Diagnostics area shows a caution. If I click on that, I can see the same message, “Drive Status: Fault.” It appears that the device is still working right now and I can access the files. Does this mean that my Drive 1 is failing, failed, or something else entirely? Any help would be appreciated. Thank you!

1 Like

It is probably worth adding that I just discovered this about an hour ago, and haven’t done anything with it yet, other than test to see if I can still access my files. Can I reboot my EX4? My fear is that the drive has failed or is going to fail, and if that happens I don’t know what the next step is. I expect that I should be able to replace the drive if it has failed and rebuild it? If that is the case, I am not sure if it is better to let it keep running, or turn it off. My gut is telling me that the drive has not failed (yet) and rebooting may solve the issue, but I want to minimize whatever damage may occur. As mentioned in my original post, this is my first experience with this and I am not sure how to fix a failed drive, only that I should be able to without losing any data on the RAID 5 configuration. Thanks!

if the drive is showing a fault that usually indicates a failed drive. You are in RAID 5 so you have redundancy and your data is safe. Just remove the failed drive and replace it with a new one (contact wd support to see if the drive is in warranty) then rebuild the RAID.

1 Like

Thanks for the response! That is what I was thinking as well. I am waiting on a response from WD Support. Does anyone know if I am okay to power down my device? Will it have any issues when I try to power it back on?

I have ordered a new replacement drive that should be here in a couple days.

After multiple days of troubleshooting with WD, I’m still not sure what went wrong. We tried a Quick Disk Test from the Utilities in the Settings tab. This took several hours and the results showed that all 4 disks passed the test successfully. Then they told me to try the full test. This took well over 48 hours, probably 60+, and also showed that all 4 disks passed successfully.

Then I backed up all of my data onto 2 4TB external My Passports, which took quite a while as well. After the data was backed up, I rebooted the EX4. When it came back online, there were no more errors and the red light above Drive 1 went away. The LCD display shows “Drive Status: Healthy”. I still have the light above the power button showing red, but that is due to the fullness (> 95%) of my RAID Volume. I think I am going to hold off on replacing the suspected bad drive for now. I will be reaching out to WD again to see if they will replace the disk under warranty while I still can.

I guess I’ll chock it up to a possible failing disk that hasn’t failed yet, or just a fluke. I feel better knowing I have a backup, and a new replacement drive ready to insert, should it ultimately fail.

Anyone have this issue or anything like it?

1 Like