Drives Failed 1,3 But Not Resolved After Replacing

I have an EX4 with 4x 3TB WD Red’s in, its been running fine for years.

Yesterday I noticed 2 red lights on it and the screen says drives 1,3 has failed. I thought it very unlucky 2 drives would have failed at the same time but the MyCloud insisted that was the fault even after a couple of reboots.

So, today I replaced the drives with 2 new WD Red’s exactly the same model, powered down the system replaced the drives and powered it back up.

I was surprised to see the same fault displayed on the screen so i thought maybe it needs some intervention in the dashboard so i try to fire that up and after putting in my username and password it comes up with a screen that says please add a hard drive and click continue. I’ve done this multiple times and nothing changes, I’ve tried removing the drives so there are none in the failed bays 1 and 3 but still the same.

I then took all the drives out, moved them around done everything i could think of and on each power cycle i either get no drives installed when there are or i get ports 1,3 and one i even saw bay 2 is red.

I have also tried the 40 second reset which still does not resolve.

I’m thinking it might actually be the MyCloud itself now but id like to hear others thoughts.


Hi F1aw1ess,

We have sent you a message. Please check your Community Message Inbox.

I am having the same issue. Was this ever resolved?

No im afraid not, the enclosure is still sat next to me, I ended up buying a new one and moving the disks to it and using roaming raid or whatever it’s called to get the data working again.