Raid volume degraded, drive failed, but healthy after rebuild, WHY?

Suddenly, a red led on drive 2:
Volume 1 degraded. Please check status of drive…
Drive failed in bay 2. Replace the failed drive. Contact WD Support.
Drive SMART failure: The drive 2 self-check failed. Contact WD Support.
Raid health: Degraded
Disk health: Bad
HWlib unable to read HD2 temperature

System test: all OK, including drive 2 !!!
Diagnostics screen says: Drive status: Fault
Check disk: no errors

During boot, all leds are flickering blue, ending up in one red led.
I got the feeling that the drive is OK, but the system refuses to use it anymore.

So I bought TB’s of external drives to backup data, took me days.
I almost sent the EX2 back to the vendor, or asking WD for a new disk.

But first:
I did a manual rebuild of the RAID
Result: drive 2 is good!
After rebuilding and rebooting: Problem solved

Why is this happening?
Is the EX2 unreliable in itself?
Does it refuse a drive when it is in a bad mood?
Is it a temperature problem? (I saw a maximum of only 52)
I read about fan problems, but this can’t be true, right?
I have used the NAS only a hundred times, and never 24/7.
So what is going on?

It could be simply bad boot. Rebuild fixed it. Dont worry much if data is safe

Thanks, but I also hope for a professional answer.
The system said the drive should be replaced, which is apparently not true.
It’s been bad for days, rebooting several times, but the problem stayed until rebuilding.
This is a serieus flaw, that could someone returning the whole unit or buy new drives.
And if it was setup as raid-0, you’re almost lost, even when the drives are okay.

If you’re still worried about the supposedly faulty drive, pull it out, connect it to a desktop somewhere, and check the SMART status of the drive, either with the Data Lifeguard Diagnostic for Windows tool, or something else like CrystalDiskInfo to confirm. Don’t take a risk with your data.

I don’t believe the drive is faulty, however I read a lot about the WD Red being not reliable. But it feels like the EX2 firmware/software is not so SMART. If it happens again, I will buy an external case and test the drive. In the meantime I keep extra backups via the USB ports.