Wd photos

I have had this WD NAS 2TB drive for 1 week now and am close to taking it back for a user friendly product.

This product is awful!

The WD Photo App that lots of people have compained about is causing me problems :

I have followed the advise from WD Tech people to restart MIONET, all this does is hangs the drive and after 40 mins of not having any access I restarted the drive and waited 1hr for the WD App to finally see the MIONET again.

However it has now been 36hrs and I only have 2481 images of 4600.

Why does this take to ridiulously long to display images? How can this be improved?

Any help would be greatly appreciated.

Hi Roseman,

I’m really sorry to hear of your bad experience. Let me give you some additional info on what is going on.

The NAS is working in the background transcoding pictures - converting them into thumbnails, and formats for your mobile device. That way when actually viewing photos - the amount of data actually being sent over is small and therefore downloads fast and doesn’t eat a lot into your data plan.

This approach was also selected because people usually have DSL / cable modem with slow upload speeds.

How large are your photos? For a 4-5MB photo, it should take about 30 - 45 s to convert. So for 4600 photos, it should take about 38 hours. (It’s a one time conversion).  The CPU on the NAS is designed for low power consumption since it’s left on all the time - hence why it takes so long.

Another thing to check is if the database on the phone is actually updated since for 36 hours I’d expect to see more of your photos converted (unless you have pictures that are more like 10MB in size). People clear cache in settings and then try. Auto-reload works but the algorithm chosen was to not ping your device often (to conserve battery power). This will be improved.

In case you’re wondering, yes I’m an employee of WD (Director of Engineering for the mobile group) and read the groups as I care about what people like you are thinking and feeling about the products. We are continuing to improve the product (we just did an update of WD Photos to 1.1.1) and there are teams working the backend (transcoder/mionet)  to improve that experience as well.

Hi, new user here. I found this post really useful as I was then prepared for my WDWE to take 6 days to process my 15k photos. However, it’s now been running 9 days and my library is now showing that I have 23k photos! What is going on? 

2 other problems - the albums in Album View do not reflect what I have in iPhoto - instead they look to be organised & named based on how the photos were stored on the camera flash (101_PANA, 100APPLE for instance). The final item is that the thumbnails are only downloaded when I scroll down - I thought that problem had been fixed in the latest v1.1.1 download?

I’ve tried clearing the cache and starting again but no change.

Any helpful WD’er out there able to explain what is happening ‘under the covers’? Is there any documentation available for the WD Photos app?



I recently bought a My Book Live 2TB drive. At the beginning I had several problems, and as I discovered later, were due to an IP conflict between a wireless bridge and the HD (I usually assign static IPs).

After that everything except for the WD Photos app works. I am able to see the pictures remotely through the mionet web interface, however each time I launch the WD photos app shows a message saying there are no photos.

I have tried clearing the cache and reinstalling the app in my iphone 4. By the way I run iOS 4.2.1. As far as I know my HD has the latest firmware which I upgraded recently.

I will appreciate comments.