WD Passport won't unlock after Mac OS update!

Hi!

I have a WD passport that won’t open! I recently updated my Mac to OS Catalina, and I think that is the reason why.

The WD SmartWare Icon appears on my desktop. When I push it, I get into a folder. When I try to open DriverUnlock I get this message:
“The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.”

What can I do?

2 Likes

I am having the exact same issue and would like to access my files!!

Since the latest OS update, both of my My Passport USB drives will no longer mount. I called WD and they told me to talk to Apple. I called Apple and they tell me to talk to WD. Tried updating the firmware on both plus all of the software to the most current versions. Still no luck. If anyone figures this out please share!

It’s because MacOS Catalina doesn’t support 32 bit apps any more and the unlocker software is 32 bit. How can we update the unlocker on the drive to a newer version?

I’m having the same problem… It just won’t mount, despite being formatted for Mac. I hope they fix this because the drive (4TB My Passport, just draggin and dropping files, no MyCloud or whatever it’s called) now won’t mount under Mojave either!

I don’t think it’s Catalina and it’s more of a security issue. I am still running High Sierra as my iMac is a bit older. Once I ran the latest OS update it stopped mounting.

As much as I hate to say this, I’m glad it’s not just me. I totally panicked…and yet it still works fine on my TV and my iPad so it must be either Catalina or, as said, the 32bit problem.

I recently upgraded to The Catalina Operating System. Now, I can’t backup with my Passport ( specifically designed for Mac.) I get a message that my backup disk is not encrypted. No, my Passport HAS been encrypted in the past. I’m thinking it is a problem with the new Catalina system. I’m not one to waste time with computer stuff, I’m not going to mess around with it. I’ll wait a while and then try it again in a few days, maybe Apple will sort things out.

Same problem here

There must be a solution to this. If not, I hope that they solve this.
I have my whole life on that hard drive :frowning:

My Passport device is a bit old so I can’t work out from the WD downloads section if there’s a software update or not? Do WD respond to this forum?

Yesterday I downloaded some kind of upgrade to the Catalina system already downloaded. Still no luck, can’t backup with my Passport. Still get a message “Device has not been encrypted.” Wrong, it has been. Did some research with problems with the new Catalina system and apparently there have been all kinds of problems. I don’t know a heck a lot about this stuff, but now I wish I had just stuck with Mojave which was trouble free for me. Hopefully Apple is on it and the bugs will get worked out soon.

After doing some more research, the problem might be on WD’s side. Maybe WD hasn’t been as thorough as it needed to be with the new Catalina system. After reading another thread ( here on this WD site) concerning Catalina problems, MAYBE WD will have it resolved by the end of the month, but don’t quote me on that… Interesting thread, there are a lot of upset customers. Again, I don’t know a heck of a lot about this stuff.

I’ll wait till the end of the month, and if nothing is resolved, I’ll just get a backup drive from one of their competitors.

I’ve got some good news!

Here’s a link to the WD security download for Mac: https://support.wdc.com/downloads.aspx?p=172#ctl00_WD_rpSoftwareMac_ctl03_lbtnExpand

I can confirm that WD Security is installable AND does work on MacOS Catalina on MacBook Pro (late 2014) models!

Install WD security and run the app. When prompted, plugin your Passport. It will then prompt you to enter your Passport password. From there, you’ll be greeted with options to update your security settings which include options to (1) remove your password, (2) set a new password, (3) add auto-unlock to your computer, and a few other items.

Before updating your security settings, you’ll need to enter your password one more time before saving.

I just did this and my drive works again on Catalina!

2 Likes

Thanks so much matey! All good now :slight_smile:

1 Like

That worked!
Thanks

1 Like

Hi DaveyJake,
Do you by any chance know if it s safe to upgrade WD: Security, Drive U. and Discovery yet still staying with Mojave? Will the new entire WD upgrade work with Mojave system?
Cheers

Glad I found this community this solved all my problems.

2 Likes

It didn’t work! The security app says that I have to unlock the drive to continue.
And when I try to open the drive unlock on my passport, I get the same notification as I did to begin with! :frowning: Any suggestions?

Dear Michael86,
I had the same issue. This solved the problem. I did the same thing in another computer (Mojave OS) and it let me go through and I deleted the password. Then my hard drive started working in Catalina OS. Hope this helps
Cheers