My Passport Essential (USB 3.0) Cannot be unlocked with DriveUnlock on MAC Catalina

Hi everyone,

I have a 2017 MacBook Pro with the most recent Catalina OS. Before I had updated to the Catalina, my WD My Passport Essential Drive could mount, unlock successfully (Driveunlock function worked), and I could access all my important documents. However, after updating to Catalina, I could still mount My Passport Drive, but it would not unlock because it said that my DriveUnlock needed to be updated. I tried to unlock My Passport Drive on another person’s Mac (earlier OS version before Catalina) and I could easily unlock and access my drive. But I need this work for my Mac.

Here is what I have tried already with no success:

  1. I have installed the latest versions of WD Utilities, WD Security, and WD Discovery. None of these would recognize my WD Passport Drive after it was connected (it was shown to be mounted in the Utilities for MAC).
  2. I’ve attempted to reach out to WD support but I only got automatic/generic FAQ responses. Nothing to help my unique situation.
  3. I have tried to ‘repair’ My Passport drive through Mac Utilities but the ‘repair’ option was greyed out and would not work.
  4. I have searched far and wide for a DriveUnlock update with no success.

Basically, nothing will work to unlock my WD Drive on my Mac because the DriveUnlock needs to be updated and there is no compatible DriveUnlock update available from what I have seen. I have spent hours…days…trying to figure this out.

Please help!!! I will really really appreciate it! Thank you!

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/28856

Hi Jonty.S

Thanks for your help!!

Unfortunately the contents of this link could not solve my issue. I have already updated to the latest and greatest versions of WD Discovery and WD Security. My Passport won’t mount in those updated APPs so I don’t have any options to Unlock it or do anything to it really. My laptop recognized My Passport and I don’t know where to go from here. Do you have any other solutions?

Hi Jonty!

This made my day! Fixed problem in just the time of downloading and press unlock + tying password.
Thnx again for your tip!

Regards
Stig Lillesveen