WD Passport mounts as Read-Only on startup

I had a 2Tb WD Passport for Mac which worked successfully for more than 2 years then backups started to fail as Time Machine reported the drive was read-only. As I had a 3-year warranty, I took it back to the shop and exchanged it for a 4Tb WD Passport (as that’s all they had in stock). I re-formatted it to be usable with my Mac, as Mac OS Extended (Journaled) but I’m having exactly the same problem with this new drive. I’m using Time Machine on Mojave. I’ve tried various things but still have the same problem. When the Mac starts up and I check the status of the WD Passport drive, it tells me it’s non-writable and has the format Mac Os Extended. If I unmount then mount the drive again in the Disk Utility application, the drive is then shown as writable and has the format Mac Os Extended (Journaled). I can then back up my machine but once I shut the Mac down, I have the same problem all over again…

What’s happening and how can I sort it?


You should try to check after reformatting the My Passport in macOS and follow the steps provided in below article specific for macOS (Mojave version).

I did follow these steps when I first set up the Passport but decided to erase again this morning. I definitely set it to the correct format but I am still having the problem; once I shut the Mac down and restart it, the format has changed as before, the Passport is read-only and so Time Machine cannot perform the backup.

Are you facing same issue when connect Passport on another Mac computer?

If yes, you need to contact WD Support for more troubleshooting in this concern.

I don’t have another Mac, unfortunately.

This gets curiouser… If I start up from a power down, the WD Passport is set as read only. If I restart the Mac, the WD Passport is writeable. I thought a power up and restart did the same things but obviously there’s something different. Does anyone have any ideas?