WD Passport Doesn't show up anymore

Hi, so I have this WD Passport for almost a year, 500GB version.

I was using it as my time machine on my Macbook Air now I connected it my other MacBook Pro, it doesn’t show up anymore on any of devices. I tried the Disk Utility, it shows it there, it just doesn’t mount it. WD icon shows up but when you press the “Mount” button it freezes, and I tried mounting using the Terminal but it just says request timed out. 

I have crucial information on my hdd I just cant lose it. 

It is possible the drive may have gotten corrupted, especially if you disconnected the drive without safely removing it first.  The fact that it still shows up in Disk Utility is an indication of that.  You might try looking for partition recovery software to see if that will restore the files.  Also, if you manually copied and pasted anything to the drive while it was connected as a TM backup drive, the drive could have become hidden.  You will have to contact Apple about that.