My Passport not showing on Mac


I have a problem with my WD My Passport 1TB for mac. I does not mount anymore. I can see it in my Disk Utility so I know it is there. I tried to repair it, but that does not help. It says it repaired it, but at one point it just sits there an veryfies. 

I have tried to use another cable with it (as someone said that might help but it won’t). 

Would be great if someone could help me out. There was a same query a month ago, but it did not get fixed. 

So please, it would help us out so much! 

Cheers, Sub

Since the drive is still on disk utility, what if you try to reformat it again on the partition tab?

What to you exactly mean with reformatting? Do you mean that I have to just erase the whole disk and then partition? 

I prefer not formatting it, as it has some data on it I’d like to recover first…


Then we have a problem, what if you try Disk Warrior then?

or have you tried it on another mac?  if it’s not showing up on your desktop, then it’s possible that there was some corruption to the drive.  if you need the data, you may have to try some data recovery software.  that’s if disk warrior doesn’t work.

I just connected my HD to my roomie’s macbook, and he was able to see it! So then I put it back in my computer and now I can see it again! 

Don’t understand why, but this solution worked! Cheers!