WD Passport Connection Issue

Hi, I have bought this WD Passport, the 4TB new version. I have been using it for a while. Today, I have connected it to my pc. It powered up but the led did not light up. I have waited for it to light up and it did not. I have disconnected it and I have heard it power down. Then, reconnected it and it worked without issue. Is this a normal issue? Does me disconnecting it without remove device safely affect it in any way because I did not have that option (remove device safely). I am a worrier so I have to ask. I do not know why this happened, to be honest, so I do not know how to prevent it.

Hi loomer,

Have you tried to change the USB cable?

Also, if you disconnect the drive without safely removing it might corrupt the data.

Hi alex, it is a brand new drive. I got two months ago and I only use it for backups. So, I must have connected it like 20 times only. I have only disconnected it because I did not have the option to actually remove it safely and the white led was not even on.

Hi loomer,

You can also safely eject the drive using WD Drive Utilities.

You should refer to the link given below in order to know how to safely eject a USB device from the computer using WD Drive Utilities.