WD Passport 2 tb external drive wont connect to computer

Hello, I have a model number WDBMWV0020BTT passport ultra 2 tb. I have used it before on my windows 7 and windows 10 computers. I had a cord issue so I replaced the cord and the thing worked, for a couple times. Now, when I plug it into either computer, the computer slows and programs start “not responding”, the “safe to remove hardware” icon shows up, the unit itself is running, vibrating, and the light on the front goes solid for a second, then blinks, solid, blink etc. I have installed the utility software and it will not recognize that the unit is plugged in. When I go to my device manager, the unit is listed but if I right or left click on the icon, the computer freezes up. When, I try to eject the unit, by clicking the eject icon, it takes about 3 minutes and then the message comes up that the generic drive cannot be safely removed. I really want to throw this thing in the trash cause I have read every FAQ and nothing has worked.
I have pc’s with windows, one has windows 7 64 and the other has windows 10

Hi there,

On both computers the drive does no show even on disk management? Try to got o disk management to see if the drive appears there.