WD Passport 1TB drive now ready only

I’ve combed this site (and others) looking for a solution to my issue, but so far one has eluded me.

I have a WD 1TB Passport external USB drive I’ve had for a few years now - model 1011B. I plugged it into my Windows 10 system (Win Pro) last night to suddenly find that the drive is now read only, and I cannot delete, edit, or add any files to it. After looking around for solutions, I’ve tried the following things:

  1. Installing the WD Smartware software, after which I disabled Security on the drive. This didn’t fix it. I then ran all three diagnostic tools available - the Status Test, the quick Diagnostic, and the full disk check. All of these diagnostic tests passed.

  2. Checked Disk Management, and attempted to see if I could make the disk writable through Disk Properties. No.

  3. Ran Diskpart and tried to mark the volume and disk not Read Only. Funny thing with this - the disk is actually showing in Diskpart as NOT Read Only. Running the ATTR commands to render the volume and disk writable regardless of that didn’t work.

  4. Edited the \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect so that it reads 0 to see if that would fix it. It didn’t fix it.

  5. Completely uninstalled the drive from my system in Device Manager after unplugging it from my machine and fully removing all WD software, after which I rebooted my system. Plugged in the drive to let it rebuild the device and install the drivers, and then checked it. Still Read Only.

  6. Exasperated at this point, I unplugged the drive and then plugged it into my wife’s laptop. Surprisingly, it was writable, and I could edit, add, or delete files to my heart’s content. Somewhat heartened, I deleted the drive from my own system’s Device Manager once again, rebooted, and then plugged in my drive just to check. Sure enough, it was still Read Only.

  7. I then tried to take ownership of the drive. This of course failed because the disk is Read Only. I did notice something strange with this though. The drive’s owner is not SYSTEM, or my account (which I am of course an Administrator) - instead it listed the typical long string of alpha numeric characters one sees when a device or file can no longer find the account that originally had ownership. I checked the registry to make sure, and that account entry didn’t exist.

At this point, I’m somewhat at a loss of what to do. I copied all the data off the drive in case it was failing somehow, but I’m still loathe to completely wipe it unless there’s no other alternative. Is there something else I can try? Have I missed something?

1 Like

I get error 0x80071ac3, same symptoms. No luck so far.