New My Passport is Read-Only - Win 10


#1

This is so frustrating - I am about to just take it back to the store. My PC sees the 1TB external drive but says it’s read only. Disk Part Read-only: No

I have been through so many threads trying different things I am not sure what all I have done. I did uninstall the drive with Disk Management and start over - got same result. So I decided to reformat. Now I have a “Disk 1” in Disk Management that has the "New Simple Volume option greyed out! (and it says Disk 1 is Read Only)

Give me a clue here!!


#2

Hello sonluver,

You can use WD Drive Utilities to erase My Passport in exFAT file format supported by Windows OS. You can download WD Drive Utilities from below link:


#3

I was still unable to get it to work. I did find a suggestion to use regedit to set the read-only flag manually and with that u was able to create the volume. However the flag flipped itself back on every time you touched it and I was never able to reformat it.

I returned the drive and got a jump drive. I think it was treating it like an internal drive _ and probably could have been fixed. However - I was not prepared to go through this every time I wanted to hook up to another laptop. I consider the product unusable for Windows 10. I would not recommend this product if you expect plug and play.

If WD expects buyers to buy this product they should include clear instructions on how to install it. You clearly know there is a problem with this - shame on you for continuing to sell it in its current state!!!


#4

Open Diskpart.exe as Administrator
type list disk
select disk number
clean
Now use your Disk management to initialize the drive and format.

If that doesn’t work use WD Utilities to format the drive even if the drive is password protect.

Remember do in so will wipe out any contents in the drive.