WD MyPassport write protected

A Windows 10 Home 64 bit laptop.
I know this has popped up a couple of times in the past but none worked to me.
I have an external 1TB WD (My Passport) which worked properly until the last couple of days, when it was not possible to create new folder or add new data anymore. Nothing changed except that at times the cable had bad connections (have to change that). It keeps saying that the disk is write protected. It does copy files out but can’t move them completely, or modify in any way.

I tried to access the WriteProtect in RegEdit but does not exist (I ended up creating it and setting it to 0).
I use a password to access the drive and remember it well, so that is off the table as well.

I am curious how other people have handled the problem.
I want to keep reformatting out of question, as I have work data on the disk and don’t want to loose it. The disk is not full yet.
Thanks a bunch.

Does it happen when the drive wakes up from hibernation mode? You can try the steps provided in the link below. Otherwise, contact support for further assistance.

I am going to reply to myself in hope that it may help someone.
What actually worked was using the command prompt (call the cmd on Windows 10) to remove the read-only status from the disk and from the volume, following this suggestion:
https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/change-external-hard-drive-from-read-only-back-to/1cc985e9-01b3-46ac-9108-8bc8e7968f36

I tried cmd also to unlock it but still its not working showing same popup that your device is write protected.
Can please help me…Thanks in advanced.