my harddrive working fine from last 6 months i am using it .
last night i found a slow performance so i download wd drive utility . and test my drive it check status check ok .
but quick drive test stuck on 90% .
after that my drive is not detect on any device not in windows or mac .
when i attached my wd passport ultra and restart my mac .
after restart only wd drive utility detect my drive but doest perform any operation not check anything i am pressing buttons but no responce . i am attaching screenshots .


Have you tried using different USB cables or ports? Also try to run a first aid on the drive to see if that can show the option to repair disk.

Yes i tried two different new cables . after installing some drivers in windows it shows my drive but shows 0MB free 0MB available .

I just solved the same problem with help from the technical support desk.

The problem is the drive utility software.

Use the uninstaller to get rid of it (you can keep the security software as is).

Disconnect your drive from the back of the Mac.

Reboot the Mac.

Plug the device back in.

Should be good to go.

There seems to be a problem with the software and El Capitan.