WD MyCloud Shutdown option

I have asked WD several times to include the shutdown option in the My Clout 4TB disk drive interface.
I live in South Africa and we have to deal with load shedding, shut down of the power for 2-2.5 hrs on a schedule of 1 to 3 times a day. The lack of a shutdown option results in a rebuild after startup and it takes forever for the drive to be ready. This is not acceptable, all other drives I have do have a shutdown option and I see no reason why this one should not have it. The drive is used by a Mac running OS Catalina
Does anyone have a solution for this?

There are many past discussions on this shutdown issue that affects the second generation single bay My Cloud units. WD has known about the many complaints both in this subforum and in the Cloud Ideas subforum for years but for what ever reason WD will not re-enable the shutdown option in the My Cloud Dashboard for the V2.x single bay My Cloud.

https://community.wd.com/search?q=shutdown%20category%3A107

One can use the forum search feature (magnifying glass icon upper right) to find those many past discussions:

https://community.wd.com/search?q=shutdown%20category%3A105

The workarounds to this issue are to use the WD recommended method for shutting down the My Cloud using the WD Quick View program. Or use a web browser hack to trigger the hidden shutdown button on the My Cloud Dashboard. Or to use SSH to issue the shutdown command. By using SSH one may be able to setup a script on their computer to issue the command when that script is run.

How to Shut Down a My Cloud Device
https://support.wdc.com/knowledgebase/answer.aspx?ID=16782

I don’t know for others but it worked for me :smile:

Enable ssh in the MyCloud Settings > Network > SSH > On
In Terminal on your Mac:
ssh root@MyCloud
(enter admin password when prompted)
shutdown -h now

I did set the password for SSH on the device and connected via “terminal”
Result:
$ ssh root@10.0.0.133
root@10.0.0.133’s password:
Permission denied, please try again.

If you have a second gen v2.x firmware single bay My Cloud, you use sshd as the SSH user name not “root”.

A couple of things to try:
ssh sshd@10.0.0.133 then use the admin password.
ssh meijereh@10.0.0.133 (i.e. a ordinary user on the MyCloud) then the user password.
If you can get access by an ordinary user, you can use sudo before any command (such as sudo shutdown) to escalate you to root.
I suggest once you get access to the MyCloud, make sure you can get root access via ssh:
sudo nano /etc/ssh/sshd_config
(root password)
Find the line #PermitRootLogin and change it to read PermitRootLogin yes.
Ctrl-o (that is a Control Key + letter O to “write out” save)
Ctrl-x (to exit)
/etc/init.d/ssh restart
exit
Note - be very careful with anything thing you do using root (or sudo) on your MyCloud - YOU CAN BRICK IT IF NOT CAREFUL !!!