Wd mycloud ftp remote access setting


I’ve followed the instructions to setup ftp remote access to a folder of mycloud ex2 ultra (that’s connected to my personal home network with lan cable), and even enabled the ftp port forwarding…
…but it doesn’t work…

FYI, I’m trying to access from remote to these ftp folder with PhotoSync app, whose purpose is to sync the photos in my iPhone with a photo folder in the nas.

I suppose there could be some other setting to be done, maybe related to IP address?

If anyone can help…thank you in advance!

You need to post exact details… anyway you should be using sftp not ftp.

Your post is like saying I overhauled my car and I now it does not start. How do I start it? You need to provide LOTS more details otherwise no one on the planet can help you.

Do you go to the doctor and say hey you don’t need to check me or ask about my symptoms. I’m sick just fix me! No you give the doctor LOTS of details.

IT help is exactly the same. You need lots of details otherwise no one can help you.

Usually experts ask for the details they need…they don’t just say I need details…otherwise I can tell you I have blue eyes and I’m 198 cm tall, but since I’m not an expert, probably these details are useless for an expert to answer.

Hi, does anybody have suggestions or needs more “details” to help me?
Thanks a LOT…

It’s very clear you need to provide more details. If you unable to provide those then as you can see no one can help you.

It seams very clear that up to now nobody wants to help, just wants to underline the technical divide between us.
Please ask which details are needed.
Maybe I could send the screenshots of all the setting pages of the NAS?
Thank you

Finally I got it to work … instead of using the FTP use SFTP server with Port Forwarding 22 to any number you like and make sure to have the SSH on and set your password.
Then use any SFTP software like FileZilla, at the host use your >>WAN IP<<, at the user use >>sshd<< at the password use >>SSH Password<<, and the port you forwarding to.
Don’t forget to open the Port Forwarding at your router.