[My Cloud EX2 Ultra] - Local access from outside with DynDns either with FTP or SFTP

Good day everyone.
Right now I struggle with my NAS Server EX2 Ultra.
I’ve been accessing it through MyCloud website but what I realized was that it doesn’t have many options in comparison to the local one. On Windows with network drive I can change the structure, create folders/subfolders, etc. MyCloud website is very restricted in this case.

So I read about creating a Dynamic DNS from no-ip.com which I did and connected the hostname with my router + WD EX2. I did and both have successfully updated. So when I try to type in the Google search bar my hostname it redirects me to the WD login dashboard. So far so good.

My problem is that I still don’t know and cannot access from another network to my WD EX2 like I would do it from home with // for example.
I tried to create a FTP server but somehow it doesn’t work. Either I do something wrong with internal or external ports (20, 21) or WD Cloud rejects the access although the option (FTP) has already been activated in settings and ports have been unblocked from the router. SFTP doesn’t work either.
What I forgot to say was that I made a static IP for NAS.

Can anyone help me with this, please? Like I mentioned, it took me days to get into this topic but still it’s not working yet.

Kind regards,

Hi @Vikiller94,

Please contact the WD Technical Support team for best assistance and troubleshooting:

Hi there @Vikiller94,

I have successfully done what you are attempting to do.

However, after I replaced my router, I had struggled to remember the entire process until recently.

Basically, you need to know about “Port Forwarding”.

Depending on your technical knowledge and skills, port forwarding may be easy or difficult, so I would advise caution if you aren’t technically experienced enough to go changing settings in your router.

Simply put, you need to allow port forwarding to your MyCloud’s internal IP address [] from the external IP [ISP Provided/no-ip hostname].

I went a different route:

I used OpenVPN to establish a VPN connection to my network. Once that is done; a PC is essentially on the network (but on a different subnet). At that point. . .enter the IP address of the NAS in file explorer. . .and you have a proper GUI interface for the files. . . (being on a different subnet; my router won’t resolve “WDMYCLOUD” in the address bar. . .but navigating using the IP address works)

Good thought.

I personally have tried that, but I am in the same boat as the OP.

They and I both have a dynamic IP supplied by our respective ISP’s, and for OpenVPN to work, you would either need a static IP, or you would need to be continuously manually updating your IP on the VPN.

However, I would like to know how you set up your OpenVPN system, as I myself have tried OpenVPN in the past, and it has never given me access to my home network.

I’m sure the OP would also like to know how you did it, especially if it allows use of a DDNS system like No-IP or DynDNS?

SO. . . I use ASUS routers these days. Embedding in even their low end units, they offer two things;

  • OpenVPN server.

OpenVPN server will run on the router, and will accept incoming internet connectons.
You then run OpenVPN client on your laptop. . .with which you dial up your home router.

For this, you kinda-need-to-know your home router IP address. . .which brings us to. . . .

  • A dynamic DDNS service.
    Basically, you sign up with a username, and a DDNS server at ASUS will provide dynamic DDNS functionality. So you get a name. . .say “Mystuffathome.asus.com” . . .which the DDNS server somewhere will translate to you home IP address. ASUS takes care of tracking your local IP address.

No-IP and DynDNS provide the same functionality

It should be noted the newer Asus routers (generally the AX series or routers that support the 388.x firmware) now include Wireguard VPN server/client support. Wireguard is supposed to be lighter weight than OpenVPN and be faster than OpenVPN as well.
[Wireless Router] How to set up WireGuard® server?
[Wireless Router] How to set up WireGuard® client in VPN Fusion?

oh snap!

Caught out on obsolete tech again! I guess it’s been a minute since I updated routers. (They work: Don’t need fixing!)