WD MyBook Live 2TB dead!?


my MBL {@Mac with OSX 10.7.4) did make problems from the first day: The front light didn’t show (any color), sometimes it was found in the sidebar under the name “NASHoe” (which I gave it), sometimes “NASHoe-”, someimes “nashoe”, sometimes with all three names at the same time!

This moday it’s GUI told me there was a new firmware to upgrade and I pushed the install button. It started to download and update, then aborted and restarted. Since then I didn’t show in the drives list, It didn’t show by searching for it in the servers list, I can’t connect it via FTP (SSH had been anabled) and of cource I could not contact it via GUI (neither with its IP nor symbolic address).

I tried to do a reset (reset button on its back), I tried to reinstall the WD-Software, I contacted the support (they only told me the things I did befor or things I first have to buy a Windows PC to do them). Nothing worked.

There is some data on the drive but at this time I don’t care about that. All I want is to do a reset and clean install and be able to use the MBL as NAS again.

So, what can I do???



Seems like the firmware did not installed correctly, if you don’t need to recover any information is better for you to replace it then.

The drive is about one year old … replacing means: discard the old drive and buy a new one??

I thought the MyBook Live has a three year warranty?