WD MyBook functionality on MacBook Pro

I connected my WD MyBook with 1TB to my MacBook Pro, and unlocked the drive.  I can see the files, and I can even open the files.  

However, I can neither copy new files to the drive nor delete files that are currently on the drive.  When I try either of these actions, I receive an error message.  For example, when trying to delete a file, I get this message:

The item “xxx” can’t be moved to the Trash because it can’t be deleted.

Any advise about how to fix this problem??

1 Like

Looks like the drive is not formatted to work with the Mac yet.

Copy the files to the computer and reformat so you can copy and edit files on the drive.

How to partition and format a WD drive on Windows (8, 7, Vista, XP) and Mac OSX


1 Like

It worked; thank you!

I had to boot-up in Safe Mode because I couldn’t mount/dismount the drive otherwise.  However, it was a fairly simple fix and now both my WD My Book and My Passport are working normally on my Mac.  



Good to know it worked.

I have the same problem trying to copy or drag my files from my Mac Pro to the external drive. It was working perfectly and now I get an error code -50. I can’t figure out what to do now. Hoping for some help. Why would it all of a sudden stop working?

any answers or solutions on this? I just got mine a few days ago and am now getting that same error code -50

Hello, all…

I, too, am having a function issue: I am on a Mac Pro using 10.6.8.

Last summer I purchased a WD My Book 2tb external, formatted it and started using. No problem…

until this morning when I went to check my email.

My screen was at the login ( I rarely turn off the mac). When I logged in I had the alert that stated

the disc I had connected was unreadable. I had, about, 600gb backup data on the WD.

Now it won’t mount; can’t see it in the finder sidebar, and, yet, disk utility sees it, but I can’t access

because it says that it is not formatted.

Can anyone suggest what options I have, and why this may have occured?

Thank you for being here!


Oh, I forgot to mention that the power button on the back of the WD drive no longer works!

I think I have solved a similar problem which appeared intermittently on a new Mac Mini, running Mavericks OS. My WD drive is a 3TB My Book Studio. The drive worked fine for a few days. Then although its icon appeared on the desktop and its contents were visible, I got error -36 when I tried to save/copy files onto it. A techsupport person at Apple suggested reformatting the drive, but Disk Utility could not unmount it. On restarting the Mac, the problem had disappeared but reappeared later when the computer woke up from sleep. I had used the WD Utilities that came with the drive to password protect this drive, and suspected that the software might be the source of the problem, since another identical drive without password protection had been problem-free. During a time when the troublesome drive was working, I used the WD Utilities again to remove password protection, then reformatted the drive, created a new partition, and copied files onto it from a backup drive. The drive has worked perfectly for several days since, so I am tentatively attributing the problem to the WD Utilities software.