Getting Started - Nothing is happening

I followed the instructions for plugging in the My Book external drive, and I can see the manufacturer’s contents, but I can’t do anything with the drive. No installation programs pop up, and none are visible on in my applications folder or any where else on my iMac.

The manual says that there should be a “WD Apps Set Up file” that I can click on and click through, but there is nothing. I also don’t see anything calling itself “WD SmartWare.”

There is a blue folder that says “WD Apps for Mac.” When I click on that, I see one icon that says “WD_Apps_1.0.1.3.dmg.” When I click on that, a warning box pops up that says “WD_Apps_1.0.1.3.dmg no mountable file systems.”

I don’t know what that means, but the bottom line is that I don’t seem to be able to use the My Book. I have tried to drag files from my “My Passbook” portable drive and from the computer to the “My Book,” but it won’t copy anything to the “My Book.”

Please help!

What’s the exact MODEL NUMBER of the drive you’re using?

The only place I see the model number is on the bottom of the device. It is soooo small. I have tried two different pairs of glasses to try to read it. I hope this is correct. Would it be located any place else?

model # E4C DDAEKA

I’m having the same issue.  WD My Book 4TB connected MacBook Pro.  WHen trying to run the WD Software for Mac it comes back with:

WD_Apps_1.0.1.3.dmg no mountable file system

I went to Best Buy where I bought the My Book, and I was told that since my iMac was running MAC OS XLion 10.7.5 that the problem was probably that the My Book would only recognize a more recent operating system. They recommended that I do the free upgrade to XYosemite. I did that upgrade just now, but I still get nothing from the My Book.

I got a complete solution to my problem. WD Support sent me this solution, but keep in mind that I had already updated my system from OS X Lion to X Yosemite.

 We sincerely apologize for the inconvenience. We checked the screenshot provided and it seems like the hard drive hasn’t been reformatted for your Mac yet.
 This device comes pre-formatted for PC. It requires to be reconfigured for your Mac. Our recommendation is to follow the steps provided on the link below so you can drag and drop files to the hard drive.

 Formatting the drive will delete all the information that you have in it. This process is Data Destructive and cannot be undone. Once the process begins, all the Data on the drive will be lost!

  1. Plug your hard drive to your Mac

2.  Once the drive appears on the desktop, double left-click on the Internal Mac drive. Choose Applications, then Utilities, and double-click on Disk Utility.

  1. In the far left pane, choose the drive to be partitioned and formatted. Typically there are two listings for each drive, unless there is more than one partition on a particular drive. Choose the option that gives you the capacity of the drive. It is usually directly above the name of the drive.

  2. There should be 5 options on the top of the Screen and you will need to click on Partition.

  3. Under Partition Layout, click the drop-down box and click on 1 partition.

  4. Click the Options button and choose GUID Partition Table. Then click on OK.

  5. Back to the Top, you will see where it says Partition Information, Name Untitled One. You can rename the drive if you wish to.

  6. Right under the name, it says Format. Make sure it says Mac OS Extended ( Journaled ).

  7. Click on Apply on the Lower right Corner and then Partition on the New Window

If you have any further questions, please reply to this email and we will be happy to assist you further.

Western Digital Service and Support

1 Like

I followed the instructions for the My Book 4T device. Plugged in to charge all night. This morning nothing seems to happen.  There is no light lit and my PC does not recognize it.  How long does it take for the battery to charge? How will I know it is fully charged?

A post was split to a new topic: No way to choose the option “Partition”