WD MyBook Duo 12tb - Snail Slow Performance

As the title says I have a 12tb MyBook Duo. It’s formatted Raid 0
USB-C straight into the computer and it’s suffering from snail slow performance. The weirdest part is that it comes and goes.

So background, when I first bought this drive it was intended for backup of old work projects (combination of video/audio files, adobe project files, png, graphic files, etc) I dumped a bunch of stuff on it and forgot about it. But I’ve recently Upgraded and (most importantly) downsized my workstation PC and now intend to use this as my primary media storage device where it will be called upon daily to access video and audio files.

But when I started transferring some footage over there it was giving me Kbs a second, literally.
Obviously something wrong.

Ran tests on it with WD drive utility and it all checked out. Tested the speed with Blackmagic Speed test and it passed. Created a few test files of around 500mbs, different file formats to make sure my other drives weren’t the issue and nope, it is the MyBook Duo.

Finally I turned off the PC, unplugged it, rebooted and plugged it back in and wouldn’t you know IT WORKED! Until it didn’t. Was able to transfer a big batch of work over to it at respectable speeds and then on the next bulk transfer it was back down to giving my like 1mbs tops.

Tried my test files again and sure enough they were slowed way down to (when it’s working they should be instantaneous)
Thinking about reformatting it but then I need to move 6tb of footage for the time being and that sounds like pain so before I do that wanted to see if anyone had any ideas

Thanks

The actual measured speed of course depends on the length of the files written.
Because you declare to have different speeds for the same sample of files, I assume written in the same succession, this is a sympton for some technical malfunction. This means to check the technical equipment used for the communication between the two devices, especially the cables and the newly used PC.